This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 986211 - [RFE] Add an option to edit "Gecos" field from IPA web UI
[RFE] Add an option to edit "Gecos" field from IPA web UI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.4
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Martin Kosek
Namita Soman
: FutureFeature
: 1008536 (view as bug list)
Depends On: 955696
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 04:56 EDT by Jan Pazdziora
Modified: 2013-11-21 15:54 EST (History)
8 users (show)

See Also:
Fixed In Version: ipa-3.0.0-31.el6
Doc Type: Enhancement
Doc Text:
Feature: GECOS field for user entries was added to Identity Management Web UI. Reason: GECOS is important user field (equals user's common name presented to the systems) and should be though editable both through CLI and Web UI interfaces. Result (if any): User's GECOS field can be displayed and changed in IdM Web UI.
Story Points: ---
Clone Of: 955696
Environment:
Last Closed: 2013-11-21 15:54:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gecos field in Webui (57.03 KB, image/png)
2013-09-06 06:01 EDT, Varun Mylaraiah
no flags Details

  None (edit)
Description Jan Pazdziora 2013-07-19 04:56:15 EDT
+++ This bug was initially created as a clone of Bug #955696 +++

This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/3569

Ticket was cloned from Red Hat Bugzilla (product ''RHEL RFE''): [https://bugzilla.redhat.com/show_bug.cgi?id=951090 Bug 951090]

''Please note that this Bug is private and may not be accessible as it contains confidential Red Hat customer information.''


Add an option to edit "Gecos" field from IPA web UI

What is the nature and description of the request?

Currently there is no option in IPA web UI to modify existing "Gecos" field,
Add an option to edit "Gecos" field from IPA web UI (This is available in ipa
command line tool, however customer would like to have it on web UI).

Why does the customer need this? (List the business requirements here)

The reason we need access to the gecos field is that we use this field for
identifing the users in different ways. Using gecos makes it the same on all
Unix/Linux operating systems.

A big issue is that we want to have the user administration done by other than
system administrators and if they cant use the IPA web gui to do what we need,
we may need to look at another product for user administration.
We can always use the ipa user-mod commands after the user is added but this
makes it a bit more complicated for others than system administrators.

--- Additional comment from Petr Vobornik on 2013-04-25 17:29:56 CEST ---

Fixed upstream:  Master: e10d934230a7f70fd9ea20a3ca96f4b8356f5664 Make gecos field editable in Web UI
Comment 1 Jan Pazdziora 2013-07-19 05:01:07 EDT
I was just debugging something. I changed the Full name on the IPA UI and was surprised that getent passwd did not pick up the change on the client. Even used sss_cache -U to no avail. Only then was I pointed to the fact that on the UI, it's cn, while on the client, it's gecos attribute which is used. Sure enough, the gecos gets populated when you create new user on IPA UI (with the Full name field, I assume) but going forward, there is no way to change what the clients will consume.

This seems like pretty serious issue because you might be then communicating with different person than you intend to when you do a search and you find completely different person based on the GECOS field than the person has listed on the UI.

Therefore I'm cloning for consideratin for RHEL 6 backport.
Comment 3 Martin Kosek 2013-07-22 07:09:50 EDT
Fixed upstream: 
Master: e10d934230a7f70fd9ea20a3ca96f4b8356f5664 Make gecos field editable in Web UI

Moving to POST.
Comment 6 Varun Mylaraiah 2013-09-06 06:01:29 EDT
Created attachment 794634 [details]
Gecos field in Webui
Comment 7 Varun Mylaraiah 2013-09-06 06:03:18 EDT
verified
ipa-server-3.0.0-33.el6.x86_64

GECOS field is present under user identity settings.
Comment 8 Martin Kosek 2013-10-01 04:11:23 EDT
*** Bug 1008536 has been marked as a duplicate of this bug. ***
Comment 10 errata-xmlrpc 2013-11-21 15:54:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1651.html

Note You need to log in before you can comment on or make changes to this bug.