Bug 986223 - win2008r2 guest BSOD after repeadly "system_powerdown" while booting guest
win2008r2 guest BSOD after repeadly "system_powerdown" while booting guest
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks: 986252 1047413
  Show dependency treegraph
 
Reported: 2013-07-19 05:22 EDT by langfang
Modified: 2014-01-14 09:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 986252 1047413 (view as bug list)
Environment:
Last Closed: 2014-01-14 09:55:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
BSOD (11.77 KB, image/png)
2013-07-19 05:27 EDT, langfang
no flags Details

  None (edit)
Description langfang 2013-07-19 05:22:41 EDT
Description of problem:

win2008r2 guest BSOD after repeadly "system_powerdown" while booting guest 

Version-Release number of selected component (if applicable):

Host:
# uname -r 
2.6.32-398.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.378.el6.x86_64

Guest:
win2008r2-64

How reproducible:

90%
Steps to Reproduce:
1.Boot guest
 /usr/libexec/qemu-kvm -M rhel6.5.0 -cpu Opteron_G3 -m 32G -smp 16,sockets=2,cores=8,threads=1 -enable-kvm -usb  -name win2008r2-64 -uuid `uuidgen` -rtc base=localtime,clock=host,driftfix=slew  -boot menu=on -drive file=/root/win2008r2-64-virtio.qcow2,if=none,id=drive-ide0-1-0,format=qcow2 -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0,bootindex=1 -vnc :11 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -serial unix:/tmp/ttyS0,server,nowait -qmp tcp:0:4445,server,nowait -monitor unix:/tmp/monitor-unix,nowait,server -monitor stdio

2.Repeadly "system_powerdown" while booting guest 
(qemu)system_powerdown
(qemu)system_powerdown
(qemu)system_powerdown
....
...
....
Actual results:

BSOD--->see attachment 

Expected results:

guest work well ,not hit BSOD

Additional info:
1)Tried rhel6.4 guest not hit the problem
2)Tried win7 guest ,hit same problem
Comment 1 langfang 2013-07-19 05:27:22 EDT
Created attachment 775709 [details]
BSOD
Comment 3 langfang 2013-07-19 05:52:19 EDT
Seabios versiopn:

# rpm -q seabios
seabios-0.6.1.2-28.el6.x86_64

Addtional info: no dump file
Comment 5 langfang 2013-07-29 22:22:43 EDT
  Test this bug on physical machine, and keeping hitting the physical power button during boot. Not hit BSOD.


thanks
Comment 7 Yan Vugenfirer 2014-01-14 09:55:54 EST
Looks like a crash in MS system service which is dependent on other service that either was not started or was already shutdown due to shutdown event.

Note You need to log in before you can comment on or make changes to this bug.