Bug 986300 - rationalise files shipped in openshift-origin-broker RPM
rationalise files shipped in openshift-origin-broker RPM
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 07:20 EDT by Jim Minter
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Extra files shipped in the broker RPM lead to confusion for some users because they appeared to be used. The extra files have been removed from the RPM in the current release to eliminate the unnecessary confusion.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 09:23:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Minter 2013-07-19 07:20:41 EDT
In openshift-origin-broker-1.5.2-1.1.el6op.noarch , there are loads of files packaged which probably shouldn't be:

See `rpm -ql openshift-origin-broker`:

For example, 

/var/www/openshift/broker/.gitignore
/var/www/openshift/broker/conf/*
/var/www/openshift/broker/doc/*
/var/www/openshift/broker/lib/*
/var/www/openshift/broker/openshift-origin-broker.spec
/var/www/openshift/broker/test/*
/var/www/openshift/broker/tmp/cache/.gitkeep

and possibly more.

The original reason for submitting the bug report was a customer reported confusion between /etc/openshift/broker.conf and /var/www/openshift/broker/conf/broker.conf; at the least we should exclude /var/www/openshift/broker/conf/* from the RPM, but I think what's needed is a wholesale evaluation of what files should actually be included.
Comment 2 Brenton Leanhardt 2013-08-15 10:52:11 EDT
I'll check if this has been fixed in Fedora.  If so, we'll defer it to the next rebase.
Comment 3 Brenton Leanhardt 2013-08-15 13:38:27 EDT
Upstream ships these files as well. Thanks for letting us know.

I'm going to handle the removal of /var/www/openshift/broker/conf/* since it was confusing to customers.  I'll clone this bug upstream to handle the rest of the spec file fixes.  The truth is there are a lot of improvements we could do to this spec file and it would be best to do the work there.
Comment 4 openshift-github-bot 2013-08-16 10:23:17 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/89f61bccb51cee80428f212ceeaf5b25b5c15a0a
Bug 986300 - Remove the unused Broker configuration directory
Comment 6 Gaoyun Pei 2013-08-18 23:09:03 EDT
Check in puddle 1.2/2013-08-16.2, configuration directory /var/www/openshift/broker/conf/ has been removed from openshift-origin-broker-1.5.8-1.el6op.noarch
Comment 7 openshift-github-bot 2013-08-20 12:20:56 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/8ac990f065a36843a04b6b3b3339b63261e457cc
Bug 986300 - Pulling in a few cleanup commits from Fedora
Comment 10 errata-xmlrpc 2013-09-05 09:23:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1211.html

Note You need to log in before you can comment on or make changes to this bug.