Bug 986311 - Unable to click 'System info' in 'Details'
Unable to click 'System info' in 'Details'
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium
: rc
: 1.3
Assigned To: Tom McKay
Tazim Kolhar
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-07-19 07:41 EDT by Vitaly Kuznetsov
Modified: 2016-04-25 20:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:12:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitaly Kuznetsov 2013-07-19 07:41:15 EDT
Description of problem:
I'm unable to click on  'System info' item in 'Details' dropdown menu (however browser shows propper link https://<hostname>/sam/systems/1759/edit at the bottom of the page (so right click -> open in new window works)

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-glue-elasticsearch-1.4.2-1.git.866.c6be614.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-repos-1.4.2-1.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-cli-1.4.2-1.git.128.53e0dde.el6.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-common-1.4.2-1.git.866.c6be614.el6.noarch
katello-cli-common-1.4.2-1.git.128.53e0dde.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-glue-candlepin-1.4.2-1.git.866.c6be614.el6.noarch
katello-headpin-all-1.4.2-1.git.866.c6be614.el6.noarch
katello-headpin-1.4.2-1.git.866.c6be614.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1. Go to 'Systems'
2. Select any system
3. Click on Subscriptions
4. Try to go back by opening 'Details' and trying to click on 'System info'

Actual results:
Unable to click (nothing happens)

Expected results:
Going to system info

Additional info:
Google Chrome google-chrome-stable-28.0.1500.71-209842 browser
Comment 1 Vitaly Kuznetsov 2013-07-19 08:16:52 EDT
(02:12:08 PM) thomasmckay: vkuznets: what i suspect is happening, because i see it on my system, is that the page is very, very slow to respond
(02:12:42 PM) thomasmckay: vkuznets: one thing that page does is contact the cdn to fetch the available release versions for choice on that page
(02:12:55 PM) thomasmckay: vkuznets: if the cdn is slow, so is the page response

yes, it really looks like it is very slow - I waited about 40 sec. after click and page appeared.
Comment 2 Tom McKay 2013-08-12 14:38:22 EDT
https://github.com/Katello/katello/pull/2734

Release versions are fetched only when editing them in the UI. This was the source of the very slow page load, which was perceived as the page not working.
Comment 4 sthirugn@redhat.com 2013-08-16 13:07:49 EDT
VERIFIED. This works fine now. There is no delay in accessing System -> Details -> System Info


* candlepin-0.8.20-1.el6sam.noarch
* candlepin-cert-consumer-cloud-qe-21.idm.lab.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 6 errata-xmlrpc 2013-10-01 07:12:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.