This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 986326 - Headpin Nightly : Creating a Org with some invalid name should fail but is passed
Headpin Nightly : Creating a Org with some invalid name should fail but is pa...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 08:20 EDT by Tazim Kolhar
Modified: 2016-04-25 20:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 12:29:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2013-07-19 08:20:54 EDT
Description of problem:
Creating a Org with some invalid name should fail but is passed

Version-Release number of selected component (if applicable):

# rpm -qa | grep katello
katello-glue-candlepin-1.4.2-1.git.852.fc1c56a.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-cli-common-1.4.2-1.git.128.53e0dde.el6.noarch
katello-common-1.4.2-1.git.852.fc1c56a.el6.noarch
katello-headpin-1.4.2-1.git.852.fc1c56a.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-headpin-all-1.4.2-1.git.852.fc1c56a.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.2-1.git.128.53e0dde.el6.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.852.fc1c56a.el6.noarch
katello-repos-1.4.2-1.el6.noarch

How reproducible:
# yum install -y katello-headpin-all
# katello-configure --deployment=headpin --user-pass=PASSWORD

Steps to Reproduce:
1.ssh root@ibm-x3650-03.ovirt.rhts.eng.bos.redhat.com export LANG=en_US; /usr/bin/headpin --username "admin" --password "admin" org create --name "orgCrt1374226370059 very < invalid name" --description "Simple description"
Stdout: Successfully created org [ orgCrt1374226370059 very < invalid name ]
Stderr:
ExitCode: 0

2. Please refer the latest test report
   - http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/job/official-headpin-cli/201/ReportNG_Report/

3.

Actual results:
A org with some invalid name is created

Expected results:
Org with invalid name fails

Additional info:
Comment 1 RHEL Product and Program Management 2013-09-17 00:22:22 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Mike McCune 2013-10-10 12:29:20 EDT
you can name orgs whatever you want.  The label gets 'converted' to an ASCII friendly value.  closing as notabug

Note You need to log in before you can comment on or make changes to this bug.