Bug 986345 - grub no boot - symbol 'grub_term_highlight_color' not found - FIXED
grub no boot - symbol 'grub_term_highlight_color' not found - FIXED
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 09:27 EDT by Bob Gustafson
Modified: 2015-02-17 11:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 11:15:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2013-07-19 09:27:02 EDT
Description of problem:

Two days ago, I did a 'yum update' and among other things, a new kernel was installed. I think the new version is 3.9.9-302.fc19

When I attempted to reboot after the kernel update, I see:

GRUB loading

error: symbol 'grub_term_highlight_color' not found.
Entering rescue mode...
grub rescue> help
Unknown command 'help'

----

When I do a 'grub2-install /dev/sda' from the install DVD (rescue mode), it seems to re-install the broken grub and I get the same error (above) when I again attempt to reboot.

Version-Release number of selected component (if applicable):

I cannot boot the affected system, but I think the grub2 version is 2.0.0-rc1

How reproducible:

Every attempt to boot comes back with same error - even though grub has been 'reinstalled' several times. /sbin/grub2-install /dev/sda completes with no error.

Steps to Reproduce:
1. Install update using 'yum update' including kernel 3.9.9-302.fc19.x86_64
2. Attempt to do a cold boot
3. Observe error: symbol 'grub_term_highlight_color' not found

Actual results:

  As above

Expected results:

  Normal boot into Fedora 19

Additional info:

I have screen photos which might possibly provide more information, but I think the

  error: symbol 'grub_term_highlight_color' not found

says it all.
Comment 1 Bob Gustafson 2013-07-19 12:51:23 EDT
On a system without the update:

I thought this was going to show more, but..

[root@hoho0 grub2]# pwd
/boot/grub2
[root@hoho0 grub2]# grep -rn grub_term_highlight_color * | sed -e "s/\(B[^e]*e \)\([^ ]*\)\(.*\)/\2/" | xargs -i ls -lt {}

-rw-r--r--. 1 root root  11480 Jul  7 05:54 i386-pc/terminfo.mod
-rw-r--r--. 1 root root 114052 Jul  7 05:54 i386-pc/normal.mod
-rw-r--r--. 1 root root  28964 Jul  7 05:54 i386-pc/kernel.img
-rw-r--r--. 1 root root  12076 Jul  7 05:54 i386-pc/gfxterm.mod
-rw-r--r--. 1 root root   2152 Jul  7 05:54 i386-pc/vga_text.mod
[root@hoho0 grub2]# 

On the system WITH the update (doing it with install DVD in rescue mode)
(hand typed from photograph)

bash-4.2# pwd
/boot/grub2
bash4-2# grep -rn grub_term_highlight_color * | sed -e "s/\(B[^e]*e \)\([^ ]*\)\(.*\)/\2/" | xargs -i ls -lt {}

-rw-r--r--. 1 root root  12076 Jul 18 21:29 i386-pc/gfxterm.mod
-rw-r--r--. 1 root root  28964 Jul 18 21:29 i386-pc/kernel.img
-rw-r--r--. 1 root root   2152 Jul 18 21:29 i386-pc/vga_text.mod
-rw-r--r--. 1 root root 114052 Jul 18 21:29 i386-pc/normal.mod
-rw-r--r--. 1 root root  11480 Jul 18 21:29 i386-pc/terminfo.mod
bash-4.2# 

The dates and times probably correspond to the last time it was installed by:
  /sbin/grub2-install /dev/sda
Comment 2 Bob Gustafson 2013-07-19 14:14:09 EDT
OK fixed.

I rebooted with the F19 Install DVD and did again the following steps:

chroot /mnt/sysimage

But, instead of doing just the 'grub2-install /dev/sda', I did:

  grub2-install --recheck /dev/sda

(Also, since it is running on a software raid, I also did the same for the /dev/sdb disk - as I had done previously)

Previously when I had done 'grub2-install --recheck /dev/sda' it came back with an error. I thought the error was related to the grub_term_highlight_color original problem.

This time both runs of grub2-install --recheck /dev/sd[ab] returned with success indications.

Afterwards, on next boot it required a selinux relabel operation. Then it rebooted again (scary..), but now is running successfully.

I don't know what really triggered the whole affair - perhaps the hot weather here..
Comment 3 Fedora End Of Life 2015-01-09 14:00:14 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2015-02-17 11:15:09 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.