Bug 986360 - [RHSC] Killing Brick Process Does Not Generate Console Event Message
[RHSC] Killing Brick Process Does Not Generate Console Event Message
Status: CLOSED DUPLICATE of bug 958813
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Sahina Bose
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 10:13 EDT by Matt Mahoney
Modified: 2013-10-25 07:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 07:47:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Mahoney 2013-07-19 10:13:37 EDT
Description of problem:
From one of the RHS servers on which there is a volume, after killing one of the brick processes the Console does not report an Event Message for the changed brick status. Note, the Console does appropriately report the brick status as being Down.

The 2nd part to the bug is that when the brick is brought up again using "volume start <volumeName force", the brick does come up but there is no event message indicating so.

Version-Release number of selected component (if applicable):
bb6

How reproducible:


Steps to Reproduce:
1. Create volume (any type)
2. Start the volume.
3. From one of the RHS nodes, kill one of the brick processes.
4. On Console, wait up to 5 minutes for the brick status to report Down
5. Verify whether or not there is an Event message for the brick status change.

6. One the same RHS node as in step-3ring the brick back up "volume start <volumeName> force", and then validate in the Console whether the event message is generated once the brick is back in Up state.

Actual results:
No event message is generate when brick status changes (from UP to Down)

Expected results:
Console should report event status for the case that a brick status has changed.

Additional info:
Comment 2 Dusmant 2013-10-25 07:47:55 EDT

*** This bug has been marked as a duplicate of bug 958813 ***

Note You need to log in before you can comment on or make changes to this bug.