Bug 986373 - The same HTTP authed site accessed from 2+ windows leads to a single auth dialog pertaining to single window, other accesses behave misleadingly
The same HTTP authed site accessed from 2+ windows leads to a single auth dia...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 11:20 EDT by Jan Pokorný
Modified: 2013-08-29 07:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 07:06:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 896253 None None None Never

  None (edit)
Description Jan Pokorný 2013-07-19 11:20:07 EDT
Just happened to me and lead me to think that the site in question
is down... "Behaves misleadingly" in the summary means that such access
will be loading infinitely until the auth dialog that belongs to the
other Firefox window (and blocking it as it is modal) is proceeded.

Thanks to being modal, this is not the case with a single window
(the dialog won't let you do anything else), but the problem emerges
with more windows.

I would expect the tabs at the other windows (i.e., the ones that
does not own the auth dialog but are blocked by the one existing
at the other window) to either bring the original dialog to front
(preferred) or at least display something like "HTTP authentication
pending", not to present infinite page load misleading the user to
think there is something wrong with the site.

This should be even greater concern if auth dialog is not window-modal
(current state) but rather tab-modal [1].  One could then get lost about
what is going on with the infinite load even with a single window
opened (common).


[1] https://bugzilla.mozilla.org/show_bug.cgi?id=613785
Comment 1 Jan Pokorný 2013-07-19 11:21:57 EDT
This was with firefox-22.0-1.fc18.x86_64, but I don't expect any change
towards more recent releases in this regard.
Comment 2 Jan Pokorný 2013-07-19 11:25:15 EDT
I expect that globally modal dialog (i.e., atop all FF windows)
-- also a possible solution -- would clash with the mentioned
heading towards tab-modal dialog.
Comment 3 Jan Pokorný 2013-07-21 05:43:08 EDT
Sidenote: having more windows opened was not desired, but a consequence
of equally annoying bug [2] and extension [3] seems to be of no help;
probably because I am using TreeStyleTab and bug489729 extension
declared incompatibility with that, unfortunately.

[2] https://bugzilla.mozilla.org/show_bug.cgi?id=489729
[3] https://addons.mozilla.org/en-us/firefox/addon/bug489729-disable-detach-and-t/versions/
Comment 4 Martin Stransky 2013-08-29 07:06:29 EDT
Let's track it upstream.

Note You need to log in before you can comment on or make changes to this bug.