Bug 986376 - break out or remove python3 dependency
break out or remove python3 dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-markdown (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 11:28 EDT by Matthew Miller
Modified: 2013-07-20 07:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-20 07:43:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2013-07-19 11:28:04 EDT
python-markdown is pulled into the cloud image by cloud-init. That's probably not right but will take quite a bit of effort to untangle.  In the meantime, python-markdown has a dependency on python3, and that's pulling that into the cloud image, which we really, really would not like to happen since it's big.


Can the python3 parts be subpackaged, or two separate versions of python-markdown be made?



Thanks!


ps: I love markdown. I love python3. not the issue here. :)
Comment 1 Thomas Moschny 2013-07-19 11:37:39 EDT
Oops, good catch. Will fix.
Comment 2 Thomas Moschny 2013-07-20 07:43:39 EDT
Fixed in python-markdown-2.3.1-2.fc20.

Note You need to log in before you can comment on or make changes to this bug.