Bug 986377 - CLI - "errata system" does not show anything
CLI - "errata system" does not show anything
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 11:38 EDT by Hayk Hovsepyan
Modified: 2014-04-24 13:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2013-07-19 11:38:44 EDT
Description of problem:
When we have some errata from zoo repo which is available on client system to install,  CLI "errata system" is not showing it in results list.

Version-Release number of selected component (if applicable):
openldap-devel-2.4.23-31.el6.x86_64
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
pulp-rpm-plugins-2.1.2-0.3.beta.el6.noarch
candlepin-0.8.17-1.el6.noarch
elasticsearch-0.19.9-7.el6.noarch
katello-all-1.4.2-1.git.866.c6be614.el6.noarch
pulp-rpm-handlers-2.1.2-0.3.beta.el6.noarch
Katello-Katello-Installation-KatelloNightly-1.0-13.noarch
katello-cli-1.4.2-1.git.128.53e0dde.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.866.c6be614.el6.noarch
Katello-Katello-Configuration-KatelloClient-1.1-50.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
openldap-2.4.23-31.el6.x86_64
python-ldap-2.3.10-1.el6.x86_64
ruby193-rubygem-ldap_fluff-0.2.2-1.el6.noarch
signo-0.0.9-1.el6.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
katello-common-1.4.2-1.git.866.c6be614.el6.noarch
katello-glue-candlepin-1.4.2-1.git.866.c6be614.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-agent-1.4.3-1.git.1.24fe511.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
Katello-Katello-Installation-ConfigureRepos-1.7-3.noarch
katello-certs-tools-1.4.2-1.el6.noarch
pulp-selinux-2.1.2-0.3.beta.el6.noarch
pulp-server-2.1.2-0.3.beta.el6.noarch
candlepin-tomcat6-0.8.17-1.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-1.4.2-1.git.866.c6be614.el6.noarch
candlepin-cert-consumer-ibm-hs21-04.lab.bos.redhat.com-1.0-1.noarch
katello-glue-pulp-1.4.2-1.git.866.c6be614.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
candlepin-selinux-0.8.17-1.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-repos-1.4.2-1.el6.noarch
katello-cli-common-1.4.2-1.git.128.53e0dde.el6.noarch
ruby193-rubygem-net-ldap-0.3.1-1.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. Create zoo repo, sync it and promote to environment via content view.
2. Register client to that environment via activation key and subscribe to zoo pool.
3. Install "walrus-0.71-1.noarch" package on client which has errata.
4. Execute "service rhsmcertd restart" and "service goferd restart;" on client side to be sure that available errata is recognized.
5. Execute CLI "errata system --org --name $systemname" and you will see empty list.

Actual results:
empty list of available erratas are shown

Expected results:
available "walrus" "RHEA-2012:0002" errata should be listed.
Comment 1 RHEL Product and Program Management 2013-09-17 00:22:18 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Mike McCune 2013-10-10 00:29:14 EDT
This is the errata applicability stuff that Justin is working on
Comment 5 Justin Sherrill 2013-10-10 13:25:03 EDT
I am working on this a part of https://bugzilla.redhat.com/show_bug.cgi?id=973834 however i suspect that potentially things were not completely configured correctly before.

For errata to show up for a system, a couple of things has to occur and one of them is that the system has to report what repositories it is bound to.  To do this:

a) katello-agent has to be installed
b) The repo must appear in /etc/yum.repos.d/redhat.repo
  For this to happen you may need to run 'yum repolist' on the client (or perform some other yum action).
Comment 6 Justin Sherrill 2013-10-14 10:47:20 EDT
Moving to modified as the bz mentioned in comment #5 should resolve this.
Comment 9 Hayk Hovsepyan 2013-10-22 04:00:33 EDT
Verified on revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
foreman-postgresql-1.3.0-18.el6sat.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
openldap-2.4.23-31.el6.x86_64
pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-candlepin-1.4.6-40.el6sat.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
Katello-Katello-Configuration-KatelloClient-1.1-53.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-13.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
foreman-1.3.0-18.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.4-1.el6sat.noarch
pulp-server-2.3.0-0.22.beta.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-pulp-1.4.6-40.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-1.4.6-40.el6sat.noarch
katello-configure-foreman-1.4.7-6.el6sat.noarch
katello-all-1.4.6-40.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
foreman-proxy-1.3.0-3.el6sat.noarch
pulp-rpm-handlers-2.3.0-0.22.beta.el6sat.noarch
katello-agent-1.4.4-3.el6sat.noarch
Katello-Katello-Installation-HammerCLI-1.0-9.noarch
katello-cli-1.4.3-24.el6sat.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
katello-configure-1.4.7-6.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
candlepin-0.8.25-1.el6sam.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
katello-common-1.4.6-40.el6sat.noarch
katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
katello-foreman-all-1.4.6-40.el6sat.noarch
candlepin-cert-consumer-artemis.usersys.redhat.com-1.0-1.noarch
signo-0.0.23-2.el6sat.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch

It shows the list of RHEL erratas correctly.
Comment 10 Bryan Kearney 2014-04-24 13:11:09 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 11 Bryan Kearney 2014-04-24 13:12:09 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.