Bug 986395 - Problems Registering and Unregistering OpenLMI Providers
Problems Registering and Unregistering OpenLMI Providers
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openlmi-providers (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Radek Novacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 12:25 EDT by Russell Doty
Modified: 2016-11-30 19:31 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-29 04:24:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Doty 2013-07-19 12:25:33 EDT
Description of problem:

OpenLMI Providers do not appear to be properly registered on installation or un-registered on un-installation


Version-Release number of selected component (if applicable):
Fedora 19, latest updates.


How reproducible:
Every time

Steps to Reproduce:
1. Install F19
2. Install and start Pegasus and YAWN
3. Setenforce 0
4. Install Storage or Network OpenLMI Providers

Actual results:
Using yawn:

* Number of Instrumented classes goes up after installing Provider.
* Number of Instrumented classes does not go down after uninstalling Providers.
* Provider classes do not show up in the cimv2 namespace
* With Network Provider installed, selecting "64 instrumented classes" fails with Broker error 6(not_found) LMI_IPNetworkConnection
* With Storage Provider installed, selecting "92 instrumented classes" fails with Broker Error 6(not found) LMI_StorageExtent
* Installing just the openlmi-providers Provider worked; I could browse the basic classes it provided and see the values. However, these classes did not show up in the cimv2 namespace.


Expected results:
* See all of the OpenLMI classes included in the Providers.
* Browse the classes with no errors
* Uninstalling a Provider should un-register the Provider classes.


Additional info:
Comment 1 Roman Rakus 2013-07-22 04:28:18 EDT
Can you please try openlmi-providers from updates-testing? There is openlmi-providers-0.0.25-2 which should fix registration problems.
Comment 2 Radek Novacek 2014-07-29 04:24:01 EDT
I'm closing this bug as there is no reply for more than year now. Looks like it has been fixed upsteam.

Note You need to log in before you can comment on or make changes to this bug.