Bug 986413 - Updating user info with option --no_default_environment fails
Updating user info with option --no_default_environment fails
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
Tazim Kolhar
: Triaged
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-07-19 13:26 EDT by Tazim Kolhar
Modified: 2016-04-25 20:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 12:32:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2013-07-19 13:26:51 EDT
Description of problem:
Updating user info with option --no_default_environment fails

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-all-1.4.2-1.git.852.fc1c56a.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.852.fc1c56a.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.2-1.git.128.53e0dde.el6.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
katello-common-1.4.2-1.git.852.fc1c56a.el6.noarch
katello-glue-pulp-1.4.2-1.git.852.fc1c56a.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-1.4.2-1.git.852.fc1c56a.el6.noarch
katello-repos-1.4.2-1.el6.noarch
katello-cli-common-1.4.2-1.git.128.53e0dde.el6.noarch
katello-glue-candlepin-1.4.2-1.git.852.fc1c56a.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch


How reproducible:
# yum install -y katello-all
# katello-configure --user-pass=***

Steps to Reproduce:
1.# katello --username "admin" --password "admin" user update --no_default_environment --username "usr-1374253642173" --default_organization "org-1374253319143" 
Usage:  katello <options> user update <options>

katello: errors:
1) Option --default_environment is required; please see --help
2) Option --no_default_environment is colliding with --default_organization, --default_environment; please see --help

2.please refer
http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/job/katello-api/171/TestNG_Report/
3.

Actual results:
the cli command fails

Expected results:
the command should be successful

Additional info:
Comment 1 Tom McKay 2013-07-22 12:32:26 EDT
This is working as intended:

The confusion,  I think, is with the default org: There is no such thing as a default org, only a default environment which exists in an org. Thus it does not make sense to specify --no_default_environment along with --default_organization; they are mutually exclusive as the message indicates.

Note You need to log in before you can comment on or make changes to this bug.