Bug 986426 - httpd won't start when nscd is running
httpd won't start when nscd is running
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Rich Megginson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 14:37 EDT by Tom Trebisky
Modified: 2013-08-09 13:10 EDT (History)
15 users (show)

See Also:
Fixed In Version: httpd-2.4.6-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 13:10:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Trebisky 2013-07-19 14:37:41 EDT
Description of problem:

httpd does not start when the nscd service is enabled.


Version-Release number of selected component (if applicable):


How reproducible:

  Always

Steps to Reproduce:
1.  enable the httpd service
2.  enable the nscd service
3.  reboot the system

Actual results:

Httpd is not running, /var/log/httpd/error_log shows:
[unique_id:alert] [pid 1011] (EAI 2)Name or service not known: AH01564: unable to find IPv4 address of "cholla.mmto.arizona.edu"


Expected results:

httpd would just start up.


Additional info:

If I do systemctl disable nscd.service and reboot, voila, I get httpd running.
I am filing this under systemd because this smells like some kind of race in
the way services get started in parallel, but I could be entirely wrong.

The workaround is to not run nscd, or to start either httpd or nscd by hand
after the system boots -- provided you are around and alert and remembering to
do do when the system boots.

I have only started noticing this with Fedora 19, but it could have been lurking
with Fedora 18 as I rarely rebooted my system prior to the F19 upgrade.  No way to tell at this time.
Comment 1 Michal Schmidt 2013-07-22 03:05:40 EDT
(In reply to Tom Trebisky from comment #0)
> I am filing this under systemd because this smells like some kind of race in
> the way services get started in parallel,

A race it may be, but first the problem should be looked at by the maintainers of the services involved. systemd just starts what it's told and it upholds the ordering dependencies expressed in unit files.
Comment 2 Jan Kaluža 2013-07-22 07:03:43 EDT
>[unique_id:alert] [pid 1011] (EAI 2)Name or service not known: AH01564: unable to find IPv4 address of "cholla.mmto.arizona.edu"

This is known problem we have fixed upstream and in rawhide already. There should be httpd-2.4.6 release soon (maximally in days). If it's not urgent, I would wait for the 2.4.6 release which we want to push into F19 too.
Comment 3 Fedora Update System 2013-07-31 10:22:33 EDT
httpd-2.4.6-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/httpd-2.4.6-2.fc19
Comment 4 Fedora Update System 2013-08-01 23:39:25 EDT
Package httpd-2.4.6-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing httpd-2.4.6-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13994/httpd-2.4.6-2.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-08-09 13:10:36 EDT
httpd-2.4.6-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.