Bug 986429 - Backupvolfile server option should work internal to GlusterFS framework
Backupvolfile server option should work internal to GlusterFS framework
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harshavardhana
:
: 989038 (view as bug list)
Depends On:
Blocks: 989038 glusterfs-3.5.1
  Show dependency treegraph
 
Reported: 2013-07-19 15:01 EDT by Harshavardhana
Modified: 2015-03-22 21:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.5.1beta
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-24 07:03:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harshavardhana 2013-07-19 15:01:49 EDT
Description of problem:
Backupvolfile server as it stands is slow and based on mount.glusterfs script. Instead in theory it should use all the available nodes in 'trusted pool' by default and should recursively attempt each before failing.

This would ensure that the clients get 'volume' configs in a consistent manner, assuming server configs are in sync always. 

Version-Release number of selected component (if applicable):
All releases

How reproducible:
Always

Actual results:
Backupvolfile only using one additional option, is prone to failures and hangs if used with mount.glusterfs

Expected results:
Backupvolfile should use all the servers in trusted pool

Additional info:

Consistency and Availability are two most important necessities of a distributed filesystem - this particular feature would enhance and augment the overall GlusterFS use case.
Comment 1 Anand Avati 2013-07-29 01:31:14 EDT
REVIEW: http://review.gluster.org/5400 (glusterfsd: Backupvolfile server option should not be in a mount script) posted (#2) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 2 Anand Avati 2013-07-29 01:38:34 EDT
REVIEW: http://review.gluster.org/5400 (glusterfsd: Backupvolfile server option should not be in a mount script) posted (#3) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 3 Anand Avati 2013-08-07 21:28:58 EDT
REVIEW: http://review.gluster.org/5400 (glusterfsd: Round robin DNS should not be relied upon with config service availability for clients.) posted (#4) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 4 Anand Avati 2013-08-09 21:03:59 EDT
REVIEW: http://review.gluster.org/5400 (glusterfsd: Round robin DNS should not be relied upon with config service availability for clients.) posted (#5) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 5 Anand Avati 2013-08-13 20:49:00 EDT
REVIEW: http://review.gluster.org/5400 (glusterfsd: Round robin DNS should not be relied upon with config service availability for clients.) posted (#6) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 6 Anand Avati 2013-08-24 10:49:51 EDT
REVIEW: http://review.gluster.org/5400 (glusterfsd: Round robin DNS should not be relied upon with config service availability for clients.) posted (#7) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 7 Anand Avati 2013-08-24 10:59:18 EDT
REVIEW: http://review.gluster.org/5400 (glusterfsd: Round robin DNS should not be relied upon with config service availability for clients.) posted (#8) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 8 Anand Avati 2013-09-04 15:54:49 EDT
REVIEW: http://review.gluster.org/5400 (glusterfsd: Round robin DNS should not be relied upon with config service availability for clients.) posted (#9) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 9 Anand Avati 2013-09-06 04:39:47 EDT
REVIEW: http://review.gluster.org/5400 (glusterfsd: Round robin DNS should not be relied upon with config service availability for clients.) posted (#10) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 10 Anand Avati 2013-09-06 15:01:41 EDT
REVIEW: http://review.gluster.org/5400 (glusterfsd: Round robin DNS should not be relied upon with config service availability for clients.) posted (#11) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 11 Anand Avati 2013-09-06 18:57:19 EDT
COMMIT: http://review.gluster.org/5400 committed in master by Anand Avati (avati@redhat.com) 
------
commit b610f1be7cd71b8f3e51c224c8b6fe0e7366c8cf
Author: Harshavardhana <harsha@harshavardhana.net>
Date:   Wed Jul 24 13:16:08 2013 -0700

    glusterfsd: Round robin DNS should not be relied upon with
    config service availability for clients.
    
    Backupvolfile server as it stands is slow and prone to errors
    with mount script and its combination with RRDNS. Instead in
    theory it should use all the available nodes in 'trusted pool'
    by default (Right now we don't have a mechanism in place for
    this)
    
    Nevertheless this patch provides a scenario where a list of
    volfile-server can be provided on command as shown below
    
    -----------------------------------------------------------------
    $ glusterfs -s server1 .. -s serverN --volfile-id=<volname> \
          <mount_point>
    -----------------------------------------------------------------
                       OR
    -----------------------------------------------------------------
    $ mount -t glusterfs -obackup-volfile-servers=<server2>: \
          <server3>:...:<serverN> <server1>:/<volname> <mount_point>
    -----------------------------------------------------------------
    
    Here ':' is used as a separator for mount script parsing
    
    Now these will be remembered and recursively attempted for
    fetching vol-file until exhausted. This would ensure that the
    clients get 'volume' configs in a consistent manner avoiding the
    need to poll through RRDNS.
    
    Change-Id: If808bb8a52e6034c61574cdae3ac4e7e83513a40
    BUG: 986429
    Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-on: http://review.gluster.org/5400
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 12 Anand Avati 2014-03-22 06:13:36 EDT
REVIEW: http://review.gluster.org/7317 (gfapi: glfs_set_volfile_server() now takes multiple hostnames) posted (#1) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 13 Anand Avati 2014-03-24 20:59:47 EDT
REVIEW: http://review.gluster.org/7317 (gfapi: glfs_set_volfile_server() now entertains multiple calls) posted (#2) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 14 Anand Avati 2014-03-24 23:37:14 EDT
REVIEW: http://review.gluster.org/7317 (gfapi: glfs_set_volfile_server() now entertains multiple calls) posted (#3) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 15 Anand Avati 2014-03-25 18:05:09 EDT
REVIEW: http://review.gluster.org/7317 (gfapi: glfs_set_volfile_server() now entertains multiple calls) posted (#4) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 16 Anand Avati 2014-03-25 21:31:57 EDT
REVIEW: http://review.gluster.org/7317 (gfapi: glfs_set_volfile_server() now entertains multiple calls) posted (#5) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 17 Anand Avati 2014-03-27 11:19:09 EDT
REVIEW: http://review.gluster.org/7317 (gfapi: glfs_set_volfile_server() now entertains multiple calls) posted (#6) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 18 Anand Avati 2014-04-01 18:06:56 EDT
COMMIT: http://review.gluster.org/7317 committed in master by Anand Avati (avati@redhat.com) 
------
commit 0c1d78f5c52c69268ec3a1d8d5fcb1a1bf15f243
Author: Harshavardhana <harsha@harshavardhana.net>
Date:   Sat Mar 22 01:33:06 2014 -0700

    gfapi: glfs_set_volfile_server() now entertains multiple calls
    
    Previous API:
    
    glfs_set_volfile_server (..., const char *host, ...) - single call
    
    New API's:
    
    glfs_set_volfile_server (..., const char *host1, ...)
    glfs_set_volfile_server (..., const char *host2, ...)
    
    Multiple calls to this function with different volfile servers,
    port or transport-type would create a list of volfile servers
    which would be polled during `volfile_fetch_attempts()`
    
    glfs_unset_volfile_server (..., const char *host, ...) to remove
    a server from the list (this is provided for future usage)
    
    Change-Id: I313efbd3efbd0214e2a71465f33195788df406cc
    BUG: 986429
    Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-on: http://review.gluster.org/7317
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 19 Anand Avati 2014-04-02 16:45:42 EDT
REVIEW: http://review.gluster.org/7384 (gfapi: glfs_set_volfile_server() now entertains multiple calls) posted (#1) for review on release-3.5 by Harshavardhana (harsha@harshavardhana.net)
Comment 20 Anand Avati 2014-04-03 01:04:54 EDT
REVIEW: http://review.gluster.org/7384 (gfapi: glfs_set_volfile_server() now entertains multiple calls) posted (#2) for review on release-3.5 by Harshavardhana (harsha@harshavardhana.net)
Comment 21 Anand Avati 2014-04-28 03:45:33 EDT
REVIEW: http://review.gluster.org/7384 (gfapi: glfs_set_volfile_server() now entertains multiple calls) posted (#3) for review on release-3.5 by Harshavardhana (harsha@harshavardhana.net)
Comment 22 Anand Avati 2014-04-30 01:45:00 EDT
REVIEW: http://review.gluster.org/7384 (gfapi: glfs_set_volfile_server() now entertains multiple calls) posted (#4) for review on release-3.5 by Harshavardhana (harsha@harshavardhana.net)
Comment 23 Anand Avati 2014-05-05 20:53:13 EDT
REVIEW: http://review.gluster.org/7384 (gfapi: glfs_set_volfile_server() now entertains multiple calls) posted (#5) for review on release-3.5 by Harshavardhana (harsha@harshavardhana.net)
Comment 24 Anand Avati 2014-05-09 22:06:49 EDT
COMMIT: http://review.gluster.org/7384 committed in release-3.5 by Niels de Vos (ndevos@redhat.com) 
------
commit ba328340e878c3156418bb3443c35a7db02a0f4b
Author: Harshavardhana <harsha@harshavardhana.net>
Date:   Wed Apr 2 13:43:36 2014 -0700

    gfapi: glfs_set_volfile_server() now entertains multiple calls
    
    Backport from - http://review.gluster.org/7317
    
    Previous API:
    
    glfs_set_volfile_server (..., const char *host, ...) - single call
    
    New API's:
    
    glfs_set_volfile_server (..., const char *host1, ...)
    glfs_set_volfile_server (..., const char *host2, ...)
    
    Multiple calls to this function with different volfile servers,
    port or transport-type would create a list of volfile servers
    which would be polled during `volfile_fetch_attempts()`
    
    glfs_unset_volfile_server (..., const char *host, ...) to remove
    a server from the list (this is provided for future usage)
    
    >> Change-Id: I313efbd3efbd0214e2a71465f33195788df406cc
    >> BUG: 986429
    >> Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    >> Reviewed-on: http://review.gluster.org/7317
    >> Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >> Reviewed-by: Niels de Vos <ndevos@redhat.com>
    >> Reviewed-by: Anand Avati <avati@redhat.com>
    
    Change-Id: If0020f6b8775bdbe987563247c83d59a2d3744ad
    BUG: 986429
    Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-on: http://review.gluster.org/7384
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 25 Niels de Vos 2014-05-25 05:06:54 EDT
The first (and last?) Beta for GlusterFS 3.5.1 has been released [1]. Please verify if the release solves this bug report for you. In case the glusterfs-3.5.1beta release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-May/040377.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/
Comment 26 Niels de Vos 2014-06-06 03:09:23 EDT
*** Bug 989038 has been marked as a duplicate of this bug. ***
Comment 27 Niels de Vos 2014-06-24 07:03:03 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.1, please reopen this bug report.

glusterfs-3.5.1 has been announced on the Gluster Users mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-June/040723.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.