Bug 986442 - Evolution cannot be used with Cyrus imap shared folders anymore
Evolution cannot be used with Cyrus imap shared folders anymore
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 15:57 EDT by Justin Albstmeijer
Modified: 2013-08-30 11:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 11:08:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evolution.log.gz (889.53 KB, application/gzip)
2013-07-19 16:52 EDT, Justin Albstmeijer
no flags Details
evolution.log.gz (UseNamespace=true) (888.10 KB, application/gzip)
2013-07-22 07:40 EDT, Justin Albstmeijer
no flags Details
evolution-old-provider.log.gz (309.23 KB, application/gzip)
2013-07-22 14:34 EDT, Justin Albstmeijer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 678216 None None None Never

  None (edit)
Description Justin Albstmeijer 2013-07-19 15:57:08 EDT
Description of problem:

Since upgrading to Fedora 19 from 18, Evolution has no choice between IMAP engines while setting up an account.
Previously I used the IMAP one instead of IMAP+/IMAPx because the last was not able to list messages in shared Cyrus IMAP folders.
But now in I can only choose IMAP+.

Version-Release number of selected component (if applicable):

evolution-3.8.3-2

How reproducible:


Steps to Reproduce:
1. setup mail account
2. browse to shared IMAP folder
3. see no messages

Actual results:

see no messages

when requesting folder properties, I see

(evolution:5637): evolution-mail-WARNING **: (em-folder-properties.c:411):emfp_dialog_got_quota_info: runtime check failed: (context->folder == NULL)

on the console

Expected results:

a list of messages Like any other MUA

Additional info:

Found someone suggesting it should work by checking “Override server-supplied folder namespace”, and leave the string empty.
But nu such option is available.

http://ingvar.blog.redpill-linpro.com/2010/03/12/working-around-shared-folder-namespace-issues-in-evolution/

Looking in .config/evolution/sources/1374259359.1850.4@localhost.localdomain.source , I see:

Namespace=
UseNamespace=false

suggesting it is the default behavoir, but it does not work.
Comment 1 Justin Albstmeijer 2013-07-19 16:52:43 EDT
Created attachment 775962 [details]
evolution.log.gz

output of

CAMEL_DEBUG=all evolution >& evolution.log

shared folder example is

user/general/info/in
Comment 2 Milan Crha 2013-07-22 04:40:48 EDT
Thanks for a bug report. I see it tries to get a quota information on a
   user/general/info/in
folder, which the server does not know - it returns:
   NO Mailbox does not exist

Is it one of the folders from the previous version of evolution, where you could read cyrus shared folders?

(In reply to Justin Albstmeijer from comment #0)
> Namespace=
> UseNamespace=false
> 
> suggesting it is the default behavoir, but it does not work.

If I read it correctly, then the suggested workaround is to have:
  Namespace=
  UseNamespace=true

(aka it should use an empty name space, which is the opposite from not using namespace override). Please change it with closed evolution.
Comment 3 Justin Albstmeijer 2013-07-22 07:39:23 EDT
Hi,

Thanks for you reply.

> Thanks for a bug report. I see it tries to get a quota information on a
> user/general/info/in folder, which the server does not know - it returns:
>    NO Mailbox does not exist
> 
> Is it one of the folders from the previous version of evolution, where you
> could read cyrus shared folders?

Yes, using imap instead of imapx

So this is a shared mailbox info/in from Cyrus imap user "general" to me.

I'm no Cyrus-imap guru, but I believe this structure has namespace "user." instead of my own maps that have namespace "INBOX."


> If I read it correctly, then the suggested workaround is to have:
>   Namespace=
>   UseNamespace=true
> 
> (aka it should use an empty name space, which is the opposite from not using
> namespace override). Please change it with closed evolution.

Tried this now, see new evolution.log.gz
But now it shows general/info/in all in one level like they are individual folders.
I still cannot see the content or request properties of the folders.

Gr, Justin
Comment 4 Justin Albstmeijer 2013-07-22 07:40:52 EDT
Created attachment 776870 [details]
evolution.log.gz (UseNamespace=true)

With

Namespace=
UseNamespace=true
Comment 5 Milan Crha 2013-07-22 13:24:48 EDT
The returned value of the NAMESPACE IMAP command is:
   * NAMESPACE (("INBOX." ".")) (("user." ".")) (("" "."))

I do not know how exactly this worked with the old IMAP provider, but please try to set in account preferences (maybe the change will require evolution's restart):
   [x] Show only subscribed folders

And left the .source file unchanges (UseNamespace=true), then open Folder->Subscriptions for the account and subscribe only to those folders you want to see.
Comment 6 Justin Albstmeijer 2013-07-22 14:32:23 EDT
> I do not know how exactly this worked with the old IMAP provider,

I have an other machine with a version of Evolution that still has the old provider configured.
See attachment: evolution-old-provider.log.gz
Maybe that sheds some light on how the old provider coped with this.

> but please try to set in account preferences (maybe the change will require 
> evolution's
> restart):
>    [x] Show only subscribed folders
> 
> And left the .source file unchanges (UseNamespace=true), then open
> Folder->Subscriptions for the account and subscribe only to those folders
> you want to see.

Sure, the folders I unsubscribe from get removed from my view.

But this means

user.general.info.in

is represented as two folders at the same level

info
in

so unsubscribing 'info' leaves me with 'in'.
not realy what you want with subfolders.
Together with an onder shared folder;

user.general.sales.in

this leaves me with two 'in' folders not distinguishable from each other.

UseNamespace=false , at least shows the correct folder structure.

Either way, I'm still not able to view any messages in these folders.
Comment 7 Justin Albstmeijer 2013-07-22 14:34:15 EDT
Created attachment 777008 [details]
evolution-old-provider.log.gz

with old working imap provider
Comment 8 Milan Crha 2013-07-23 01:04:01 EDT
Ah, I see, the IMAP+ account doesn't honour server-supplied directory separator (which is a dot) when you've the namespace override. That's the reason for "flat" folder view.
Comment 9 Justin Albstmeijer 2013-07-23 03:54:11 EDT
> Ah, I see, the IMAP+ account doesn't honour server-supplied directory
> separator (which is a dot) when you've the namespace override. That's the
> reason for "flat" folder view.

And this would also explain that it is not able to show the messages in the folder? Or is that a separate issue?
Comment 10 Milan Crha 2013-07-23 06:22:36 EDT
It's the same issue, the server returns "folder not found", because evolution tries to open the folder name as a single folder with dots in its name, instead of dots being used as a directory separator.
Comment 11 Milan Crha 2013-08-30 11:08:03 EDT
I thought I'll test this myself, but I do not have proper setup currently. I accidentally found an upstream bug [1] for this, thus I suggest to move there, because it's not a fedora specific issue. Thank you for your help with the investigation.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=678216

Note You need to log in before you can comment on or make changes to this bug.