Bug 986458 - gluster-swift-gen-builders should show user where the ring files are created
gluster-swift-gen-builders should show user where the ring files are created
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-swift (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: crisbud@redhat.com
pushpesh sharma
:
: 986456 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 16:38 EDT by Luis Pabón
Modified: 2016-11-08 17:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Pabón 2013-07-19 16:38:40 EDT
Description of problem:
When running gluster-swift-gen-builders no summary output is given.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. gluster-swift-gen-builders <account...>
2.
3.

Actual results:
Only the swift command output is given

Expected results:
Show where the ring files have been created, and if not in /etc/swift, suggest to the user to overwrite the /etc/swift ring files with the new ones.


Additional info:
Comment 2 crisbud@redhat.com 2013-07-24 05:55:01 EDT
Should we modify the script to cd to /etc/swift directory prior to start ? 

Rather thank asking user to copy it to /etc/swift.
Comment 3 crisbud@redhat.com 2013-07-24 06:21:44 EDT
IMO, the rings file generated by gluster-swift-gen-builders should need to overwrite the existing ring files in order get started. I can provide an option of backing up earlier ring file <if any> to a backup_ring_files folder in /etc/swift. Please let me know if this make sense.
Comment 4 crisbud@redhat.com 2013-07-26 04:27:35 EDT
luster-swift-gen-builders behaviour changes

gluster-swift-gen-builders copies the older ring files to
/etc/swift/backup_ring. And then creates the new ring files to /etc/swift
BUG: 986458
Change-Id: I06e93179e46da56d5046419e66c8864aa08f184d
Signed-off-by: Chetan Risbud <crisbud@redhat.com>
Reviewed-on: http://review.gluster.org/5384
Reviewed-by: Luis Pabon <lpabon@redhat.com>
Tested-by: Luis Pabon <lpabon@redhat.com>


Merged to upstream
Comment 5 crisbud@redhat.com 2013-08-07 04:28:35 EDT
http://review.gluster.org/#/c/5457/

merged to release 1.8 as well.
Comment 7 Luis Pabón 2013-08-13 16:57:23 EDT
In version gluster-swift-plugin-1.8.0-6
Comment 8 pushpesh sharma 2013-08-19 08:58:18 EDT
[root@mater ~]# gluster-swift-gen-builders test test2
mkdir: cannot create directory `/etc/swift/backup_rings': File exists
WARNING: No region specified for z1-127.0.0.1:6012/test_. Defaulting to region 1.
Device r1z1-127.0.0.1:6012/test_"" with 100.0 weight got id 0
WARNING: No region specified for z2-127.0.0.1:6012/test2_. Defaulting to region 1.
Device r1z2-127.0.0.1:6012/test2_"" with 100.0 weight got id 1
Reassigned 2 (100.00%) partitions. Balance is now 0.00.
account.builder, build version 2
2 partitions, 1.000000 replicas, 1 regions, 2 zones, 2 devices, 0.00 balance
The minimum number of hours before a partition can be reassigned is 1
Devices:    id  region  zone      ip address  port      name weight partitions balance meta
             0     1     1       127.0.0.1  6012      test 100.00          1   0.00 
             1     1     2       127.0.0.1  6012     test2 100.00          1   0.00 
mkdir: cannot create directory `/etc/swift/backup_rings': File exists
WARNING: No region specified for z1-127.0.0.1:6011/test_. Defaulting to region 1.
Device r1z1-127.0.0.1:6011/test_"" with 100.0 weight got id 0
WARNING: No region specified for z2-127.0.0.1:6011/test2_. Defaulting to region 1.
Device r1z2-127.0.0.1:6011/test2_"" with 100.0 weight got id 1
Reassigned 2 (100.00%) partitions. Balance is now 0.00.
container.builder, build version 2
2 partitions, 1.000000 replicas, 1 regions, 2 zones, 2 devices, 0.00 balance
The minimum number of hours before a partition can be reassigned is 1
Devices:    id  region  zone      ip address  port      name weight partitions balance meta
             0     1     1       127.0.0.1  6011      test 100.00          1   0.00 
             1     1     2       127.0.0.1  6011     test2 100.00          1   0.00 
mkdir: cannot create directory `/etc/swift/backup_rings': File exists
WARNING: No region specified for z1-127.0.0.1:6010/test_. Defaulting to region 1.
Device r1z1-127.0.0.1:6010/test_"" with 100.0 weight got id 0
WARNING: No region specified for z2-127.0.0.1:6010/test2_. Defaulting to region 1.
Device r1z2-127.0.0.1:6010/test2_"" with 100.0 weight got id 1
Reassigned 2 (100.00%) partitions. Balance is now 0.00.
object.builder, build version 2
2 partitions, 1.000000 replicas, 1 regions, 2 zones, 2 devices, 0.00 balance
The minimum number of hours before a partition can be reassigned is 1
Devices:    id  region  zone      ip address  port      name weight partitions balance meta
             0     1     1       127.0.0.1  6010      test 100.00          1   0.00 
             1     1     2       127.0.0.1  6010     test2 100.00          1   0.00 



 mater proxy-server Client disconnected without sending enough data (txn: tx12da5da3632c4b3ca20c47a53f8a941f) (client_ip: 127.0.0.1)
Aug 18 15:15:51 mater proxy-server 127.0.0.1 127.0.0.1 18/Aug/2013/19/15/51 PUT /v1/AUTH_test/dir/10.img HTTP/1.0 499 - curl/7.19.7%20%28x86_64-redhat-linux-gnu%29%20libcurl/7.19.7%20NSS/3.14.3.0%20zlib/1.2.3%20libidn/1.18%20libssh2/1.4.2 test%2CAUTH_tke4a76ae4646e48b8ac626771cd1d6578 1777876992 89 - tx12da5da3632c4b3ca20c47a53f8a941f - 24.9707 -
Aug 18 17:28:54 mater kernel: hrtimer: interrupt took 15531974 ns


[root@mater ~]# rpm -qa|grep swift
gluster-swift-container-1.8.0-6.11.el6rhs.noarch
python-swiftclient-1.4.0-1.el6.noarch
gluster-swift-plugin-1.8.0-6.el6rhs.noarch
gluster-swift-proxy-1.8.0-6.11.el6rhs.noarch
gluster-swift-account-1.8.0-6.11.el6rhs.noarch
gluster-swift-1.8.0-6.11.el6rhs.noarch
gluster-swift-object-1.8.0-6.11.el6rhs.noarch
[root@mater ~]#
Comment 9 crisbud@redhat.com 2013-08-20 09:11:08 EDT
New code changes are posted for review and merged to master, upstream. 

http://review.gluster.org/#/c/5658/
Comment 10 crisbud@redhat.com 2013-08-29 02:09:19 EDT
Changes have been merged to release 1.8 as well. 

http://review.gluster.org/#/c/5667/
Comment 11 Luis Pabón 2013-09-10 13:16:35 EDT
*** Bug 986456 has been marked as a duplicate of this bug. ***
Comment 13 pushpesh sharma 2013-09-11 02:48:54 EDT
[root@mater etc]# gluster-swift-gen-builders test
WARNING: No region specified for z1-127.0.0.1:6012/test_. Defaulting to region 1.
Device r1z1-127.0.0.1:6012/test_"" with 100.0 weight got id 0
Reassigned 2 (100.00%) partitions. Balance is now 0.00.
account.builder, build version 1
2 partitions, 1.000000 replicas, 1 regions, 1 zones, 1 devices, 0.00 balance
The minimum number of hours before a partition can be reassigned is 1
Devices:    id  region  zone      ip address  port      name weight partitions balance meta
             0     1     1       127.0.0.1  6012      test 100.00          2   0.00 
WARNING: No region specified for z1-127.0.0.1:6011/test_. Defaulting to region 1.
Device r1z1-127.0.0.1:6011/test_"" with 100.0 weight got id 0
Reassigned 2 (100.00%) partitions. Balance is now 0.00.
container.builder, build version 1
2 partitions, 1.000000 replicas, 1 regions, 1 zones, 1 devices, 0.00 balance
The minimum number of hours before a partition can be reassigned is 1
Devices:    id  region  zone      ip address  port      name weight partitions balance meta
             0     1     1       127.0.0.1  6011      test 100.00          2   0.00 
WARNING: No region specified for z1-127.0.0.1:6010/test_. Defaulting to region 1.
Device r1z1-127.0.0.1:6010/test_"" with 100.0 weight got id 0
Reassigned 2 (100.00%) partitions. Balance is now 0.00.
object.builder, build version 1
2 partitions, 1.000000 replicas, 1 regions, 1 zones, 1 devices, 0.00 balance
The minimum number of hours before a partition can be reassigned is 1
Devices:    id  region  zone      ip address  port      name weight partitions balance meta
             0     1     1       127.0.0.1  6010      test 100.00          2   0.00 
Ring files are prepared in /etc/swift


[root@mater etc]# rpm -qa|grep swift
gluster-swift-container-1.8.0-6.11.el6rhs.noarch
gluster-swift-proxy-1.8.0-6.11.el6rhs.noarch
gluster-swift-account-1.8.0-6.11.el6rhs.noarch
gluster-swift-plugin-1.8.0-7.el6rhs.noarch
gluster-swift-1.8.0-6.11.el6rhs.noarch
gluster-swift-object-1.8.0-6.11.el6rhs.noarch

Ring files are created in /etc/swift irrespective of where the gen builder is ran.
Marking as fix, based on the above observation.
Comment 14 Scott Haines 2013-09-23 18:32:33 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.