Bug 986459 - renew_ca_cert fails on upgraded system with separate CA dirsrv instancce
renew_ca_cert fails on upgraded system with separate CA dirsrv instancce
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Kosek
Namita Soman
:
: 986461 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 16:43 EDT by Dmitri Pal
Modified: 2013-07-23 10:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 10:40:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2013-07-19 16:43:35 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/3805

I update to F18 my old ipa server that has been upgraded since F15.

It has stil a separate directory instance for the CA.

When certmonger decided to renrew the CA certificate renew_ca_cert failed to update the CA instance users with the renewd certs.

the reason is that renew_ca_cert tried to perform all its operations against the main IPA instance and not the CA instanace on port 7389 where these objects actually are.
all renew_ca_cert operation terminated with 'no such entry' until certmonger failed to update certs as the RA certificate didn't match the cA user anymore.
Comment 1 Dmitri Pal 2013-07-19 16:45:46 EDT
*** Bug 986461 has been marked as a duplicate of this bug. ***
Comment 2 Jan Cholasta 2013-07-23 09:15:14 EDT
I have just verified that this bug in fact does *not* affect RHEL 6.4. It only affects installs updated from Dogtag 9 to Dogtag 10.
Comment 3 Martin Kosek 2013-07-23 10:40:14 EDT
Thank you, I will close the bug then.

Note You need to log in before you can comment on or make changes to this bug.