Bug 986480 - [abrt] dnf-0.3.9-1.giteff4c49.fc19: repo.py:102:__init__:TypeError: 'NoneType' object has no attribute '__getitem__'
[abrt] dnf-0.3.9-1.giteff4c49.fc19: repo.py:102:__init__:TypeError: 'NoneType...
Status: CLOSED DUPLICATE of bug 977661
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:832eef0eeff31de81ebad4c12c9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 17:42 EDT by monts
Modified: 2013-07-22 01:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 01:47:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.58 KB, text/plain)
2013-07-19 17:42 EDT, monts
no flags Details
File: core_backtrace (1.12 KB, text/plain)
2013-07-19 17:42 EDT, monts
no flags Details
File: environ (4.26 KB, text/plain)
2013-07-19 17:42 EDT, monts
no flags Details

  None (edit)
Description monts 2013-07-19 17:42:31 EDT
Description of problem:
dnf stopped working ...

Version-Release number of selected component:
dnf-0.3.9-1.giteff4c49.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/bin/dnf update
executable:     /usr/bin/dnf
kernel:         3.11.0-0.rc1.git1.2.fc20.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
repo.py:102:__init__:TypeError: 'NoneType' object has no attribute '__getitem__'

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 292, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 74, in main
    return 1
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 130, in __exit__
    self.close()
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 253, in close
    self._store_persistent_data()
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 177, in _store_persistent_data
    expired = [r.id for r in self.repos.iter_enabled() if check_expired(r)]
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 173, in check_expired
    return repo.metadata_expire_in()[1] <= 0
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 417, in metadata_expire_in
    self._try_cache()
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 256, in _try_cache
    self.metadata = self._handle_load(handle)
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 201, in _handle_load
    return Metadata(result, handle)
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 102, in __init__
    self._mirrors = handle.mirrors[:]
TypeError: 'NoneType' object has no attribute '__getitem__'

Local variables in innermost frame:
res: <librepo.Result object at 0xb2ee18>
self: <dnf.repo.Metadata object at 0xb27dd0>
handle: <dnf.repo._Handle object at 0xb26ba8>
Comment 1 monts 2013-07-19 17:42:36 EDT
Created attachment 775977 [details]
File: backtrace
Comment 2 monts 2013-07-19 17:42:39 EDT
Created attachment 775978 [details]
File: core_backtrace
Comment 3 monts 2013-07-19 17:42:44 EDT
Created attachment 775979 [details]
File: environ
Comment 4 Ales Kozumplik 2013-07-22 01:47:27 EDT
Hello,

this is a known problem triggered through KeyboardInterrupt exception. Please see bug 977661. The current status is that this issue will be resolved with the next librepo version.

*** This bug has been marked as a duplicate of bug 977661 ***

Note You need to log in before you can comment on or make changes to this bug.