Bug 986506 - Need to determine RPM packages to be excluded from compose . . .
Need to determine RPM packages to be excluded from compose . . .
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Harmsen
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 20:31 EDT by Matthew Harmsen
Modified: 2013-12-02 09:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-02 09:34:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to exclude pki-kra, pki-ocsp, and pki-tks from RHEL 7 (11.74 KB, patch)
2013-07-24 18:30 EDT, Matthew Harmsen
no flags Details | Diff
Patch to exclude pki-kra, pki-ocsp, and pki-tks from RHEL 7 (12.03 KB, patch)
2013-07-24 21:23 EDT, Matthew Harmsen
no flags Details | Diff

  None (edit)
Description Matthew Harmsen 2013-07-19 20:31:33 EDT
Per the following discussion on IRC and after chatting with Nathan, we probably need to inform Release Engineering which packages need to be excluded from their RHEL 7 compose:

    <mharmsen> alee, edewata: does RHEL 7.0 include all RPM packages that are a part of pki-core SRPM (regardless of whether or not they are supported)?
    <mharmsen> nkinder: ^^^^
    <mharmsen> alee, edewata, nkinder: the reason that I am asking this is actually because of pki-symkey --- since it is a JNI library, it needs to be checked on RHEL 7 to make certain that it is going to the same place as JSS on RHEL 7
    <nkinder> mharmsen: not sure if subpackages can be tagged independently for the compose or not.
    <nkinder> mharmsen: perhaps kwright knows
    <kwright> nkinder: for composes, they use xml files which can list individual packages and/or subpackages
    * kwright not technically "tagged"
    <kwright> although, they also can use tagging for composes
    <kwright> but tags can't be used for subpackages
    <kwright> tags can only be used for packages
    <nkinder> kwright, mharmsen: thanks!  So that means we can choose to exclude our unused subpackages from the compose.
    <mharmsen> alee, edewata, nkinder: this means that we should not be including pki-symkey (and don't have to worry about it being built from Dogtag 10.0 as it will be correctly from Dogtag 10.1/RHEL 7.x)
    <kwright> nkinder: is this for rhel-7?
    <mharmsen> kwright: yes
    <kwright> mharmsen: then I would file a release-engineering ticket and dmach or one of the rhel-7 guys will handle it
    <nkinder> kwright: yes, rhel7
    <kwright> see ^^
    <mharmsen> kwright, nkinder: sending email reminder to alee and edewata to discuss which packages should be excluded so that we can do this

I did not file a TRAC ticket on this because it is specific to RHEL, and does not apply to Fedora.
Comment 2 Matthew Harmsen 2013-07-22 17:53:55 EDT
Exclude the following 'pki-core' subpackages from the RHEL 7 'compose':
* pki-symkey
* pki-kra
* pki-ocsp
* pki-tks
Comment 3 Matthew Harmsen 2013-07-24 13:21:33 EDT
On July 22, the following release ticket was filed:
* https://engineering.redhat.com/rt/Ticket/Display.html?id=240073  Request to remove specific 'pki-core' subpackages from RHEL 7 compose . . .

  The ticket was rejected with the following comment:
  
  Dne Po 22.čec.2013 17:56:10, mharmsen@redhat.com napsal(a):
  Show quoted text
  Why don't you simply stop creating these subpackages in the spec file?
  
  Good practice is to exclude packages on compose level only on certain arches
  (typically if a package is compiled on an arch but doesn't work on it or we
  don't want to ship it for some business reason).
  
  In this case, I'd really recommend adding couple %if-s to the spec.


Consequently, a discussion took place on IRC with nkinder and alee, and it was determined that we would add the logic to exclude building these four packages (on RHEL 7 only) to the pki-core.spec file.
Comment 4 Matthew Harmsen 2013-07-24 18:30:21 EDT
Created attachment 778009 [details]
Patch to exclude pki-kra, pki-ocsp, and pki-tks from RHEL 7
Comment 5 Matthew Harmsen 2013-07-24 21:23:50 EDT
Created attachment 778026 [details]
Patch to exclude pki-kra, pki-ocsp, and pki-tks from RHEL 7
Comment 6 Matthew Harmsen 2013-07-24 21:27:09 EDT
(In reply to Matthew Harmsen from comment #5)
> Created attachment 778026 [details]
> Patch to exclude pki-kra, pki-ocsp, and pki-tks from RHEL 7

This replacement patch replaced the original patch as ACKed by Endi S. Dewata via email:

As mentioned over IRC, just one minor thing, the pki-symkey dependency in pki-tks can be removed because it's already added to pki-server. Everything else is good. ACK.
Comment 7 Matthew Harmsen 2013-07-24 21:48:33 EDT
DOGTAG_10_0_BRANCH:

# cd pki
# git add .
# git commit
# git push
https://git.fedorahosted.org/cgit/pki.git/commit/?h=DOGTAG_10_0_BRANCH&id=0a42bd576b4b7beb6d6a560f692e85eb11c56e66

Note You need to log in before you can comment on or make changes to this bug.