Bug 986558 - (process:2658): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
(process:2658): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_siz...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1008688
  Show dependency treegraph
 
Reported: 2013-07-20 11:37 EDT by Nicolas Mailhot
Modified: 2015-06-29 08:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-29 08:06:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (10.25 KB, text/plain)
2014-01-04 20:15 EST, Peter H. Jones
no flags Details

  None (edit)
Description Nicolas Mailhot 2013-07-20 11:37:51 EDT
Description of problem:

(process:2658): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

Version-Release number of selected component (if applicable):
gnome-abrt-0.2.12-3.fc20.x86_64

How reproducible:
When selecting a bug to report
Comment 1 Jakub Filak 2013-07-22 04:37:25 EDT
Thank you for the bug report. Unfortunately, without a stack trace from the crash it is impossible to determine what caused the crash. Please see http://fedoraproject.org/wiki/StackTraces for more information about getting a useful stack trace with debugging symbols and see https://developer.gnome.org/glib/2.30/glib-running.html#G-DEBUG:CAPS for more information about debugging GLib based applications. Even if you cannot reproduce this crash at will, you can prepare your system now to produce a good stack trace the next time you experience the crash. Thank you.
Comment 2 Trevor Cordes 2013-08-08 06:46:34 EDT
Bug (think it's the same one) is also in firefox.  It is being worked on upstream:

https://bugzilla.mozilla.org/show_bug.cgi?id=833117

also

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1160569

Can reproduce by simply starting firefox from the command line.

Bug exists in Fedora 19 with all updates as of today, so can remove rawhide
Comment 3 Fedora End Of Life 2013-09-16 10:40:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 20 development cycle.
Changing version to '20'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora20
Comment 4 Peter H. Jones 2014-01-04 17:15:31 EST
I get this every time in Fedora 19 with:
"firefox www.sttr.qc.ca/images/images/pdf/4789_sttr_depliant_8.pdf

(process:11254): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
"

I tried to get the stack trace as suggested in comment 1, but ran out of disk space installing the 10G or so of debugging packages. Perhaps someone with more space can reproduce this bug.

I can view the pdf if I download and use evince for viewing, but I also get error diagnostics:
"[jones@mariehe Desktop]$ evince 4789_sttr_depliant_8.pdf
Syntax Warning: Invalid Font Weight
*** BUG ***
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug

*** BUG ***
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug

*** BUG ***
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug

*** BUG ***
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug

Syntax Warning: Invalid Font Weight
Syntax Warning: Invalid Font Weight
Syntax Warning: Invalid Font Weight
Syntax Warning: Invalid Font Weight
Syntax Warning: Invalid Font Weight
Syntax Warning: Invalid Font Weight
Syntax Warning: Invalid Font Weight
Syntax Warning: Invalid Font Weight
Syntax Warning: Invalid Font Weight
Syntax Warning: Invalid Font Weight
"

My evince is evince-3.8.3-2.fc19.x86_64. The file is from the city's public transit site.
Comment 5 Peter H. Jones 2014-01-04 19:02:13 EST
After enlarging my root partitiion, I think I only needed 2G, and not 20G more, and perhaps a 500M during the download. After running firefox as in comment 1 and trying to access the PDF, gdb produced a request for more more debugging packages. Here is the list:
"expat-debuginfo.x86_64 0:2.1.0-5.fc19 graphite2-debuginfo.x86_64 0:1.2.2-2.fc19 harfbuzz-debuginfo.x86_64 0:0.9.19-1.fc19
libICE-debuginfo.x86_64 0:1.0.8-5.fc19         
libSM-debuginfo.x86_64 0:1.2.1-5.fc19             libXau-debuginfo.x86_64 0:1.0.8-1.fc19         
  libXcomposite-debuginfo.x86_64 0:0.4.4-3.fc19     libXcursor-debuginfo.x86_64 0:1.1.14-1.fc19    
  libXdamage-debuginfo.x86_64 0:1.1.4-3.fc19        libXfixes-debuginfo.x86_64 0:5.0.1-1.fc19      
  libXi-debuginfo.x86_64 0:1.7.2-1.fc19             libXinerama-debuginfo.x86_64 0:1.1.3-1.fc19    
  libXrandr-debuginfo.x86_64 0:1.4.1-1.fc19         libXxf86vm-debuginfo.x86_64 0:1.1.3-1.fc19     
  libcap-debuginfo.x86_64 0:2.22-6.fc19             libdrm-debuginfo.x86_64 0:2.4.49-2.fc19        
  libgcrypt-debuginfo.x86_64 0:1.5.3-2.fc19         libgpg-error-debuginfo.x86_64 0:1.11-1.fc19    
  libpciaccess-debuginfo.x86_64 0:0.13.1-3.fc19     libpng-debuginfo.x86_64 2:1.5.13-2.fc19        
  libselinux-debuginfo.x86_64 0:2.1.13-15.fc19      libxcb-debuginfo.x86_64 0:1.9-3.fc19           
  mesa-debuginfo.x86_64 0:9.2.4-1.20131128.fc19     pam-debuginfo.x86_64 0:1.1.6-12.fc19           
  pcre-debuginfo.x86_64 0:8.32-7.fc19               pixman-debuginfo.x86_64 0:0.30.0-1.fc19        
  systemd-debuginfo.x86_64 0:204-18.fc19            util-linux-debuginfo.x86_64 0:2.23.2-4.fc19    
  wayland-debuginfo.x86_64 0:1.2.0-1.fc19           xcb-util-debuginfo.x86_64 0:0.3.9-2.fc19       
  xz-debuginfo.x86_64 0:5.1.2-4alpha.fc19"
Comment 6 Peter H. Jones 2014-01-04 20:15:06 EST
Created attachment 845622 [details]
backtrace

Got a backtrace using the following:
1) Start a terminal with script
2) firefox -g
3) start -safe-mode
4) (Click on "Start in Safe Mode" that appears)
5) Enter "http://www.sttr.qc.ca/images/images/pdf/4789_sttr_depliant_8.pdf" in the address bar of Firefox
6) In terminal, type "bt" to get traceback
7) Post typescript here

Note in output:
"Line 39, No module named backtrace"
"Line 118, SIGSEV"
Comment 7 Jonathan Ryshpan 2014-02-10 01:19:18 EST
This bug is being followed in two mozilla threads:
https://bugzilla.mozilla.org/show_bug.cgi?id=833117 and
https://bugzilla.mozilla.org/show_bug.cgi?id=672671
Comment 8 Nix\ 2014-02-11 01:39:02 EST
Related? https://bugzilla.redhat.com/show_bug.cgi?id=1014858
Comment 9 Fedora End Of Life 2015-05-29 05:12:06 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2015-06-29 08:06:42 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.