Bug 986594 - Maven repo: Java plugin specified as a dependency with absolute systemPath
Maven repo: Java plugin specified as a dependency with absolute systemPath
Status: CLOSED WONTFIX
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal Packaging (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium
: ER04
: 6.1.0
Assigned To: hfnukal@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-20 17:06 EDT by Miroslav Cupák
Modified: 2015-01-05 06:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 20:56:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Cupák 2013-07-20 17:06:26 EDT
Description of problem:
The following dependency can be found in org/gatein/sso/sso-parent/1.3.3.Final-redhat-1/sso-parent-1.3.3.Final-redhat-1.pom.

<dependency>
  <groupId>java</groupId>
  <artifactId>plugin</artifactId>
  <version>1.5</version>
  <scope>system</scope>
  <systemPath>/usr/share/icedtea-web/plugin.jar</systemPath>
</dependency>

This causes problems with portability and raises errors when trying to construct the dependency tree on a machine without the plugin on the specified path.
Comment 2 hfnukal@redhat.com 2013-08-22 07:00:43 EDT
icedtea need to be installed on machine. This is requirement for SSO.

Assign to Marek, he can explain in more detail why it needs to be like that.
Comment 3 mposolda 2013-08-23 05:33:52 EDT
Artifact org.josso:josso-applet-agent:1.8.5 declares this system dependency:

<dependency>
  <groupId>java</groupId>
  <artifactId>plugin</artifactId>
  <version>1.5</version><systemPath>${JAVA_HOME}/jre/lib/plugin.jar</systemPath>
  <scope>system</scope>
</dependency>

This is not a problem for build with Oracle SDK as plugin.jar is available on the required path:
/home/mposolda/software/jdk1.6.0_32/jre/lib/plugin.jar
/home/mposolda/software/jdk1.7.0_05/jre/lib/plugin.jar 

However for productized build with OpenJDK it seems to be an issue because plugin.jar is not available in requested path as part of JDK but it's available as part of icedtea in /usr/share/icedtea-web/plugin.jar . So at this moment it seems that it's requirement for OpenJDK to have the file on the path /usr/share/icedtea-web/plugin.jar
Comment 4 hfnukal@redhat.com 2013-08-30 20:56:23 EDT
PRoductized build in mead requires icedtea. Thats why path needs to be overriden.

Note You need to log in before you can comment on or make changes to this bug.