This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 986623 - riak uses versioned absolute path to escript, so it fails to start with Erlang R16B01
riak uses versioned absolute path to escript, so it fails to start with Erlan...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: riak (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 01:12 EDT by Mark
Modified: 2013-11-10 01:54 EST (History)
5 users (show)

See Also:
Fixed In Version: couchdb-1.3.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 02:30:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2013-07-21 01:12:00 EDT
Description of problem:

riak cannot be started in Fedora 19 because it cannot find escript.

[jmbrooks@fedora19 ~]$ sudo systemctl status riak.service
riak.service - Riak Distributed Data Store
   Loaded: loaded (/usr/lib/systemd/system/riak.service; enabled)
   Active: failed (Result: exit-code) since Sun 2013-07-21 01:04:38 EDT; 4s ago
  Process: 2230 ExecStart=/usr/bin/riak start (code=exited, status=1/FAILURE)

Jul 21 01:04:38 fedora19.jmbnet systemd[1]: Starting Riak Distributed Data Store...
Jul 21 01:04:38 fedora19.jmbnet riak[2230]: !!!!
Jul 21 01:04:38 fedora19.jmbnet riak[2230]: !!!! WARNING: ulimit -n is 1024; 4096 is the recommended minimum.
Jul 21 01:04:38 fedora19.jmbnet riak[2230]: !!!!
Jul 21 01:04:38 fedora19.jmbnet riak[2230]: /usr/bin/riak: line 100: /usr/lib64/riak/erts-5.10.1/bin/escript: No such file or directory
Jul 21 01:04:38 fedora19.jmbnet riak[2230]: /usr/bin/riak: line 136: /usr/lib64/riak/erts-5.10.1/bin/escript: No such file or directory
Jul 21 01:04:38 fedora19.jmbnet systemd[1]: riak.service: control process exited, code=exited status=1
Jul 21 01:04:38 fedora19.jmbnet systemd[1]: Failed to start Riak Distributed Data Store.
Jul 21 01:04:38 fedora19.jmbnet systemd[1]: Unit riak.service entered failed state.

Also it appears that installing riak doesn't set the ulimit correctly.

Version-Release number of selected component (if applicable):

riak-1.3.1-2.fc19.x86_64

How reproducible:

Install riak and related erlang riak rpms.
Enable riak.
Attempt to start riak.

Actual results:

[jmbrooks@fedora19 ~]$ sudo systemctl status riak.service
riak.service - Riak Distributed Data Store
   Loaded: loaded (/usr/lib/systemd/system/riak.service; enabled)
   Active: failed (Result: exit-code) since Sun 2013-07-21 01:04:38 EDT; 4s ago
  Process: 2230 ExecStart=/usr/bin/riak start (code=exited, status=1/FAILURE)

Jul 21 01:04:38 fedora19.jmbnet systemd[1]: Starting Riak Distributed Data Store...
Jul 21 01:04:38 fedora19.jmbnet riak[2230]: !!!!
Jul 21 01:04:38 fedora19.jmbnet riak[2230]: !!!! WARNING: ulimit -n is 1024; 4096 is the recommended minimum.
Jul 21 01:04:38 fedora19.jmbnet riak[2230]: !!!!
Jul 21 01:04:38 fedora19.jmbnet riak[2230]: /usr/bin/riak: line 100: /usr/lib64/riak/erts-5.10.1/bin/escript: No such file or directory
Jul 21 01:04:38 fedora19.jmbnet riak[2230]: /usr/bin/riak: line 136: /usr/lib64/riak/erts-5.10.1/bin/escript: No such file or directory
Jul 21 01:04:38 fedora19.jmbnet systemd[1]: riak.service: control process exited, code=exited status=1
Jul 21 01:04:38 fedora19.jmbnet systemd[1]: Failed to start Riak Distributed Data Store.
Jul 21 01:04:38 fedora19.jmbnet systemd[1]: Unit riak.service entered failed state.

Expected results:

(1) It should not complain about the ulimit.
(2) Riak should start and run normally.

Additional info:
Comment 1 Peter Lemenkov 2013-07-21 02:19:56 EDT
That's an issue with Erlang R16B01 from updates-testing. Please downgrade to R16B. I'm working on resolving this.
Comment 2 Bernard Fouché 2013-07-31 06:00:07 EDT
I have a similar ulimit problem while upgrading the cluster from F18 to F19, however riak isn't complaining about escript. 

AFAIK, I'm running R16B:

[root@riak4-vm1 bin]# rpm -qa|grep riak
erlang-riak_kv-1.3.1-1.fc19.x86_64
erlang-riak_core-1.3.1-2.fc19.x86_64
erlang-riak_pb-1.3.3-1.fc19.x86_64
erlang-riak_api-1.3.1-2.fc19.x86_64
riak-1.3.1-2.fc19.x86_64
erlang-riak_err-1.0.1-4.fc19.x86_64
erlang-riak_pipe-1.3.1-2.fc19.x86_64
erlang-riak_control-1.3.1-1.fc19.x86_64
erlang-riak_search-1.3.1-1.fc19.x86_64
erlang-riak_sysmon-1.1.3-2.fc19.x86_64
[root@riak4-vm1 bin]# 

Jul 31 11:56:08 riak4-vm1 systemd[1]: Starting Riak Distributed Data Store...
Jul 31 11:56:08 riak4-vm1 riak[5059]: !!!!
Jul 31 11:56:08 riak4-vm1 riak[5059]: !!!! WARNING: ulimit -n is 1024; 4096 is the recommended minimum.
Jul 31 11:56:08 riak4-vm1 riak[5059]: !!!!
Jul 31 11:56:10 riak4-vm1 riak[5164]: Starting up
Jul 31 11:56:11 riak4-vm1 systemd[1]: Started Riak Distributed Data Store.
Jul 31 11:56:13 riak4-vm1 run_erl[5163]: Erlang closed the connection.
[root@riak4-vm1 bin]# ps xau|grep riak
avahi      428  0.0  0.0  27936  1508 ?        Ss   11:34   0:00 avahi-daemon: running [riak4-vm1.local]
riak      5114  0.0  0.0  11572   332 ?        S    11:56   0:00 /usr/lib64/riak/erts-5.10.1/bin/epmd -daemon
root      5546  0.0  0.0 112636   968 ttyS0    R+   11:56   0:00 grep --color=auto riak
[root@riak4-vm1 bin]# su - riak
[riak@riak4-vm1 ~]$ ulimit -n
100000
[riak@riak4-vm1 ~]$ 

The system was previously running fine with F18 and riak-1.3.1-fc17.x86_64.rpm.

How can I restore the cluster functioning until the problem is definitely fixed?

Thanks!

 Bernard
Comment 3 Bernard Fouché 2013-07-31 06:01:59 EDT
oops, forgot to list Erlang packages:

[root@riak4-vm1 riak]# rpm -qa|grep erlang
erlang-tools-R16B-0.3.fc19.x86_64
erlang-riak_kv-1.3.1-1.fc19.x86_64
erlang-crypto-R16B-0.3.fc19.x86_64
erlang-eleveldb-1.3.0-2.fc19.x86_64
erlang-sext-1.1-1.fc19.x86_64
erlang-mustache-0.1.0-5.fc19.x86_64
erlang-mochiweb-2.4.2-2.fc19.x86_64
erlang-et-R16B-0.3.fc19.x86_64
erlang-riak_core-1.3.1-2.fc19.x86_64
erlang-dialyzer-R16B-0.3.fc19.x86_64
erlang-compiler-R16B-0.3.fc19.x86_64
erlang-runtime_tools-R16B-0.3.fc19.x86_64
erlang-basho_stats-1.0.3-1.fc19.x86_64
erlang-ssl-R16B-0.3.fc19.x86_64
erlang-erl_interface-R16B-0.3.fc19.x86_64
erlang-riak_pb-1.3.3-1.fc19.x86_64
erlang-erts-R16B-0.3.fc19.x86_64
erlang-kernel-R16B-0.3.fc19.x86_64
erlang-mnesia-R16B-0.3.fc19.x86_64
erlang-merge_index-1.3.0-1.fc19.x86_64
erlang-asn1-R16B-0.3.fc19.x86_64
erlang-getopt-0.7.0-1.fc19.x86_64
erlang-public_key-R16B-0.3.fc19.x86_64
erlang-edoc-R16B-0.3.fc19.x86_64
erlang-lfe-0.6.2-2.fc19.x86_64
erlang-eper-0.60-4.20120621git16bae32.fc19.x86_64
erlang-webtool-R16B-0.3.fc19.x86_64
erlang-os_mon-R16B-0.3.fc19.x86_64
erlang-riak_api-1.3.1-2.fc19.x86_64
erlang-gettext-2.1.0-0.6.20101022gitb55cb72.fc19.x86_64
erlang-rebar-2.1.0-0.4.fc19.x86_64
erlang-appmon-R16B-0.3.fc19.x86_64
erlang-protobuffs-0.8.0-1.fc19.x86_64
erlang-snmp-R16B-0.3.fc19.x86_64
erlang-syntax_tools-R16B-0.3.fc19.x86_64
erlang-lager-1.2.2-1.fc19.x86_64
erlang-eunit-R16B-0.3.fc19.x86_64
erlang-poolboy-0.9.1-2.fc19.x86_64
erlang-folsom-0.7.4-1.fc19.x86_64
erlang-erlsom-1.2.1-12.20120904gitdef76b9.fc19.x86_64
erlang-neotoma-1.6.0-1.fc19.x86_64
erlang-observer-R16B-0.3.fc19.x86_64
erlang-riak_err-1.0.1-4.fc19.x86_64
erlang-riak_pipe-1.3.1-2.fc19.x86_64
erlang-erlydtl-0.7.0-1.20130214git6a9845f.fc19.x86_64
erlang-riak_control-1.3.1-1.fc19.x86_64
erlang-webmachine-1.10.1-1.fc19.x86_64
erlang-wx-R16B-0.3.fc19.x86_64
erlang-cluster_info-1.2.3-1.fc19.x86_64
erlang-reltool-R16B-0.3.fc19.x86_64
erlang-hipe-R16B-0.3.fc19.x86_64
erlang-xmerl-R16B-0.3.fc19.x86_64
erlang-bear-0.1.3-1.fc19.x86_64
erlang-inets-R16B-0.3.fc19.x86_64
erlang-js-1.2.2-1.fc19.x86_64
erlang-otp_mibs-R16B-0.3.fc19.x86_64
erlang-gtknode-0.32-4.20110310git19ddfd5.fc19.x86_64
erlang-sasl-R16B-0.3.fc19.x86_64
erlang-riak_search-1.3.1-1.fc19.x86_64
erlang-stdlib-R16B-0.3.fc19.x86_64
erlang-bitcask-1.6.1-1.fc19.x86_64
erlang-riak_sysmon-1.1.3-2.fc19.x86_64
erlang-ebloom-1.1.2-1.fc19.x86_64
erlang-gs-R16B-0.3.fc19.x86_64
[root@riak4-vm1 riak]#
Comment 4 Bernard Fouché 2013-07-31 09:29:44 EDT
I was able to backtrack to my previous config with:

- yum remove 'erlang*' riak
- yum install ./riak-1.3.1-1.fc17.x86_64.rpm (previous RPM I was using)
- restore vm.args and app.config in /etc/riak (were changed to *.rpmsave)
Comment 5 Bernard Fouché 2013-07-31 11:31:29 EDT
Still had ulimit problems when launching riak from systemctl, even when backtracking to riak-1.3.1-1.fc17.x86_64.rpm that includes its own erlang vm, I wasn't able go over 1024 files while the system is setup in /etc/security/limits.conf to allow up to 100K files, soft and hard limits, whatever the user.

However I could  launch riak correctly by typing 'riak start', so I added 'LimitNOFILE=infinity' into /usr/lib/systemd/system/riak.service and it seems ok.
Comment 6 Peter Lemenkov 2013-07-31 13:08:29 EDT
Bernard, we can't help you with your particular issue - you're probably using Basho's own build, and therefore should ask them for help.
Comment 7 Bernard Fouché 2013-08-01 03:49:25 EDT
The Fedora package also lacks something like 'LimitNOFILE=infinity' (see the OP report), I just tested it again and it fails because of 'ulimit -n' reporting 1024 instead of the system wide limit.
Comment 8 Mark 2013-08-01 11:28:45 EDT
(In reply to Peter Lemenkov from comment #6)
> Bernard, we can't help you with your particular issue - you're probably
> using Basho's own build, and therefore should ask them for help.

I don't know about Bernard, but I'm encountering the same problem with the Fedora package.  It complains about the ulimit, no matter how high I set it, so there must be something wrong with how it checks for the ulimit.

May I suggest that the package set the ulimit for the running instance to the appropriate level, or something of the sort?

The ulimit issue isn't due to a foreign package.
Comment 9 Bernard Fouché 2013-08-02 03:41:50 EDT
Mark, in /usr/lib/systemd/system/riak.service add 'LimitNOFILE=infinity'.

Check also that /etc/security/limits.conf allows for the riak user (or '*') very high values for hard and soft limits for 'nofile' (I use 100000).

That should fix the ulimit problem when riak starts and IMHO riak.service should be fixed in the Fedora package.
Comment 10 Peter Lemenkov 2013-08-02 05:29:42 EDT
Folks, a small followup from me - I'm working on update to 1.3.2 with fixed ulimit issue, R16B01 compatibility, and version-dependent escript/nodetool issue resolved. I've build finally all the necessary packages, and it will take me ~1-2 weeks to submit them to Fedora repositories (4 packages from 10 left).

(In reply to Bernard Fouché from comment #9)
> Mark, in /usr/lib/systemd/system/riak.service add 'LimitNOFILE=infinity'.

Yes, this will work. However a proper and recommended way is to copy riak.service to /etc/systemd/system and edit it there. Any service-files from /etc/systemd/system will override service-files of the same name from /usr/lib/systemd/system/
Comment 11 Fedora Update System 2013-08-06 14:36:46 EDT
erlang-riak_search-1.3.2-1.fc19, riak-1.3.2-1.fc19, erlang-R16B-01.1.fc19, erlang-riaknostic-1.1.0-1.fc19, erlang-sidejob-0.2.0-2.fc19, erlang-riak_kv-1.3.2-1.fc19, erlang-eleveldb-1.3.2-1.fc19, erlang-riak_core-1.3.2-1.fc19, erlang-riak_pipe-1.3.2-1.fc19, erlang-bitcask-1.6.3-1.fc19, erlang-riak_api-1.3.2-2.fc19, erlang-riak_control-1.3.2-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/riak-1.3.2-1.fc19,erlang-R16B-01.1.fc19,erlang-riak_search-1.3.2-1.fc19,erlang-riak_kv-1.3.2-1.fc19,erlang-riaknostic-1.1.0-1.fc19,erlang-sidejob-0.2.0-2.fc19,erlang-riak_control-1.3.2-3.fc19,erlang-riak_api-1.3.2-2.fc19,erlang-bitcask-1.6.3-1.fc19,erlang-riak_pipe-1.3.2-1.fc19,erlang-riak_core-1.3.2-1.fc19,erlang-eleveldb-1.3.2-1.fc19
Comment 12 Fedora Update System 2013-08-07 19:05:32 EDT
Package erlang-riak_search-1.3.2-1.fc19, riak-1.3.2-1.fc19, erlang-R16B-01.1.fc19, erlang-riaknostic-1.1.0-1.fc19, erlang-sidejob-0.2.0-2.fc19, erlang-riak_kv-1.3.2-1.fc19, erlang-eleveldb-1.3.2-1.fc19, erlang-riak_core-1.3.2-1.fc19, erlang-riak_pipe-1.3.2-1.fc19, erlang-bitcask-1.6.3-1.fc19, erlang-riak_api-1.3.2-2.fc19, erlang-riak_control-1.3.2-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing erlang-riak_search-1.3.2-1.fc19 riak-1.3.2-1.fc19 erlang-R16B-01.1.fc19 erlang-riaknostic-1.1.0-1.fc19 erlang-sidejob-0.2.0-2.fc19 erlang-riak_kv-1.3.2-1.fc19 erlang-eleveldb-1.3.2-1.fc19 erlang-riak_core-1.3.2-1.fc19 erlang-riak_pipe-1.3.2-1.fc19 erlang-bitcask-1.6.3-1.fc19 erlang-riak_api-1.3.2-2.fc19 erlang-riak_control-1.3.2-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14411/riak-1.3.2-1.fc19,erlang-R16B-01.1.fc19,erlang-riak_search-1.3.2-1.fc19,erlang-riak_kv-1.3.2-1.fc19,erlang-riaknostic-1.1.0-1.fc19,erlang-sidejob-0.2.0-2.fc19,erlang-riak_control-1.3.2-3.fc19,erlang-riak_api-1.3.2-2.fc19,erlang-bitcask-1.6.3-1.fc19,erlang-riak_pipe-1.3.2-1.fc19,erlang-riak_core-1.3.2-1.fc19,erlang-eleveldb-1.3.2-1.fc19
then log in and leave karma (feedback).
Comment 13 Peter Lemenkov 2013-08-08 05:11:49 EDT
Guys, this issue still not addressed fully, so you need to manually type this (as superuser):

# ln -s /usr/lib64/erlang/erts-5.10.2 /usr/lib64/riak/erts-5.10.2

or 

# ln -s /usr/lib/erlang/erts-5.10.2 /usr/lib/riak/erts-5.10.2

depending on your architecture. Will fix this in the following build. Again, sorry for that - I have no idea how this slipped through except that I became more stupid with time.
Comment 14 Fedora Update System 2013-08-15 19:31:31 EDT
erlang-riak_search-1.3.2-1.fc19, riak-1.3.2-1.fc19, erlang-R16B-01.1.fc19, erlang-riaknostic-1.1.0-1.fc19, erlang-sidejob-0.2.0-2.fc19, erlang-riak_kv-1.3.2-1.fc19, erlang-eleveldb-1.3.2-1.fc19, erlang-riak_core-1.3.2-1.fc19, erlang-riak_pipe-1.3.2-1.fc19, erlang-bitcask-1.6.3-1.fc19, erlang-riak_api-1.3.2-2.fc19, erlang-riak_control-1.3.2-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Peter Lemenkov 2013-08-16 00:34:46 EDT
Ok, reopening this again.
Comment 16 Dan Keyes 2013-09-02 20:39:54 EDT
Hi Peter,

You said the solution is to type the following:

# ln -s /usr/lib64/erlang/erts-5.10.2 /usr/lib64/riak/erts-5.10.2

I just installed Fedora 19 and Riak, but I have no /usr/lib64/riak/erts-5.10.2 directory.  It appears to me that the Riak RPM is not working properly.

[root@localhost dkeyes]# rpm -q riak
riak-1.3.2-1.fc19.x86_64

[dkeyes@localhost ~]$ rpm -ql riak 
/etc/riak
/etc/riak/app.config
/etc/riak/vm.args
/usr/bin/riak
/usr/bin/riak-admin
/usr/bin/riak-nodetool
/usr/bin/search-cmd
/usr/lib/systemd/system/riak.service
/usr/lib/tmpfiles.d/riak.conf
/usr/lib64/erlang/lib/riak-1.3.2
/usr/lib64/erlang/lib/riak-1.3.2/ebin
/usr/lib64/erlang/lib/riak-1.3.2/ebin/etop_txt.beam
/usr/lib64/erlang/lib/riak-1.3.2/ebin/riak.app
/usr/lib64/riak
/usr/lib64/riak/lib
/usr/lib64/riak/releases
/usr/lib64/riak/releases/1.3.2
/usr/lib64/riak/releases/1.3.2/riak.boot
/usr/lib64/riak/releases/1.3.2/riak.rel
/usr/lib64/riak/releases/1.3.2/riak.script
/usr/lib64/riak/releases/1.3.2/start_clean.boot
/usr/lib64/riak/releases/1.3.2/start_clean.rel
/usr/lib64/riak/releases/1.3.2/start_clean.script
/usr/lib64/riak/releases/RELEASES
/usr/lib64/riak/releases/start_erl.data
/usr/share/doc/riak-1.3.2
/usr/share/doc/riak-1.3.2/LICENSE
/usr/share/doc/riak-1.3.2/NOTICE
/usr/share/doc/riak-1.3.2/README.org
/usr/share/doc/riak-1.3.2/RELEASE-NOTES.md
/usr/share/doc/riak-1.3.2/THANKS
/usr/share/doc/riak-1.3.2/admin.org
/usr/share/doc/riak-1.3.2/architecture.txt
/usr/share/doc/riak-1.3.2/basho-doc-style.iorg
/usr/share/doc/riak-1.3.2/basic-client.txt
/usr/share/doc/riak-1.3.2/basic-setup.txt
/usr/share/doc/riak-1.3.2/doc-style.css
/usr/share/doc/riak-1.3.2/raw-http-howto.txt
/usr/share/doc/riak-1.3.2/releasenotes
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.1.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.10.1.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.10.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.11.0.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.12.0.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.12.1.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.13.0.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.14.0.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.2.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.3.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.4.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.5.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.6.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.7.1.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.7.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.8.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.9.1.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-0.9.txt
/usr/share/doc/riak-1.3.2/releasenotes/riak-1.0.org
/usr/share/doc/riak-1.3.2/releasenotes/riak-1.1.org
/usr/share/doc/riak-1.3.2/releasenotes/riak-1.2.0.md
/usr/share/man/man1/riak-admin.1.gz
/usr/share/man/man1/riak.1.gz
/usr/share/man/man1/search-cmd.1.gz
/var/lib/riak
/var/lib/riak/bitcask
/var/lib/riak/dets
/var/lib/riak/leveldb
/var/lib/riak/merge_index
/var/lib/riak/mr_queue
/var/lib/riak/ring
/var/log/riak
/var/log/riak/sasl
/var/run/riak

[root@localhost dkeyes]# rpm -q erlang
erlang-R16B-01.1.fc19.x86_64

[root@localhost dkeyes]# which run_erl
/usr/bin/run_erl
Comment 17 Dan Keyes 2013-09-02 21:02:11 EDT
Please disregard my earlier comment.  The suggested fix works.
Comment 18 Dan Keyes 2013-09-02 21:48:17 EDT
Just a few more words for infrequent Linux users such as me.  The RPM does not need to create a directory named /usr/lib64/riak/erts-5.10.2.  Instead, the Erlang runtime is located at /usr/lib64/erlang/erts-5.10.2. The /usr/bin/riak script attempts to build the path to the Erlang runtime, but it uses the directory name "riak" where it should have used "erlang".  The easiest solution is the one suggested by Peter: 

# ln -s /usr/lib64/erlang/erts-5.10.2 /usr/lib64/riak/erts-5.10.2

An alternative would be to fix the /usr/bin/riak script.

The next problem that you might run into is the following:

!!!!
!!!! WARNING: ulimit -n is 1024; 4096 is the recommended minimum.
!!!!

A solution is as follows: 

# ulimit -n 8192

Then start riak using:
 
# riak start
Comment 19 Francesco Frassinelli (frafra) 2013-10-02 12:36:21 EDT
I can confirm what Dan Keyes said.
I have no warning regarding ulimit.
Comment 20 Fedora Update System 2013-10-28 09:10:06 EDT
couchdb-1.3.1-3.fc19, erlang-erlsyslog-0.6.2-4.fc19, erlang-esdl-1.3.1-2.fc19, erlang-js-1.2.2-3.fc19, erlang-esasl-0.1-13.20120116git665cc80.fc19, ejabberd-2.1.13-7.fc19, erlang-R16B-02.3.fc19, wings-1.4.1-8.git9a2473e.fc19, riak-1.3.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-20045/riak-1.3.2-2.fc19,ejabberd-2.1.13-7.fc19,couchdb-1.3.1-3.fc19,wings-1.4.1-8.git9a2473e.fc19,erlang-js-1.2.2-3.fc19,erlang-esdl-1.3.1-2.fc19,erlang-esasl-0.1-13.20120116git665cc80.fc19,erlang-erlsyslog-0.6.2-4.fc19,erlang-R16B-02.3.fc19
Comment 21 Fedora Update System 2013-10-28 09:14:28 EDT
couchdb-1.3.1-3.fc20, erlang-erlsyslog-0.6.2-4.fc20, erlang-esasl-0.1-13.20120116git665cc80.fc20, erlang-esdl-1.3.1-2.fc20, erlang-js-1.2.2-3.fc20, ejabberd-2.1.13-7.fc20, erlang-R16B-02.3.fc20, wings-1.4.1-8.git9a2473e.fc20, riak-1.3.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-20029/riak-1.3.2-2.fc20,ejabberd-2.1.13-7.fc20,couchdb-1.3.1-3.fc20,wings-1.4.1-8.git9a2473e.fc20,erlang-js-1.2.2-3.fc20,erlang-esdl-1.3.1-2.fc20,erlang-esasl-0.1-13.20120116git665cc80.fc20,erlang-erlsyslog-0.6.2-4.fc20,erlang-R16B-02.3.fc20
Comment 22 Fedora Update System 2013-10-28 15:17:40 EDT
Package couchdb-1.3.1-3.fc20, erlang-erlsyslog-0.6.2-4.fc20, erlang-esasl-0.1-13.20120116git665cc80.fc20, erlang-esdl-1.3.1-2.fc20, erlang-js-1.2.2-3.fc20, ejabberd-2.1.13-7.fc20, erlang-R16B-02.3.fc20, wings-1.4.1-8.git9a2473e.fc20, riak-1.3.2-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing couchdb-1.3.1-3.fc20 erlang-erlsyslog-0.6.2-4.fc20 erlang-esasl-0.1-13.20120116git665cc80.fc20 erlang-esdl-1.3.1-2.fc20 erlang-js-1.2.2-3.fc20 ejabberd-2.1.13-7.fc20 erlang-R16B-02.3.fc20 wings-1.4.1-8.git9a2473e.fc20 riak-1.3.2-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20029/riak-1.3.2-2.fc20,ejabberd-2.1.13-7.fc20,couchdb-1.3.1-3.fc20,wings-1.4.1-8.git9a2473e.fc20,erlang-js-1.2.2-3.fc20,erlang-esdl-1.3.1-2.fc20,erlang-esasl-0.1-13.20120116git665cc80.fc20,erlang-erlsyslog-0.6.2-4.fc20,erlang-R16B-02.3.fc20
then log in and leave karma (feedback).
Comment 23 Fedora Update System 2013-11-06 02:30:56 EST
couchdb-1.3.1-3.fc19, erlang-erlsyslog-0.6.2-4.fc19, erlang-esdl-1.3.1-2.fc19, erlang-js-1.2.2-3.fc19, erlang-esasl-0.1-13.20120116git665cc80.fc19, ejabberd-2.1.13-7.fc19, erlang-R16B-02.3.fc19, wings-1.4.1-8.git9a2473e.fc19, riak-1.3.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Fedora Update System 2013-11-10 01:54:32 EST
couchdb-1.3.1-3.fc20, erlang-erlsyslog-0.6.2-4.fc20, erlang-esasl-0.1-13.20120116git665cc80.fc20, erlang-esdl-1.3.1-2.fc20, erlang-js-1.2.2-3.fc20, ejabberd-2.1.13-7.fc20, erlang-R16B-02.3.fc20, wings-1.4.1-8.git9a2473e.fc20, riak-1.3.2-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.