Bug 986624 - SELinux is preventing /usr/sbin/glusterfsd from 'read' accesses on the file ip_local_reserved_ports.
SELinux is preventing /usr/sbin/glusterfsd from 'read' accesses on the file i...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7e5a20881bdb4713228c07f9f41...
:
: 986625 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 01:48 EDT by Marcel Wysocki
Modified: 2013-07-26 19:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-66.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 19:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Wysocki 2013-07-21 01:48:36 EDT
Description of problem:
systemctl start glusterd.service
SELinux is preventing /usr/sbin/glusterfsd from 'read' accesses on the file ip_local_reserved_ports.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that glusterfsd should be allowed read access on the ip_local_reserved_ports file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep glusterfs /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:glusterd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:sysctl_net_t:s0
Target Objects                ip_local_reserved_ports [ file ]
Source                        glusterfs
Source Path                   /usr/sbin/glusterfsd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           glusterfs-3.4.0-0.9.beta4.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-65.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-302.fc19.x86_64 #1 SMP Sat
                              Jul 6 13:41:07 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-21 07:47:50 CEST
Last Seen                     2013-07-21 07:47:50 CEST
Local ID                      77d2bec9-a76a-4e49-8ce1-b95cf3c051a6

Raw Audit Messages
type=AVC msg=audit(1374385670.400:4664): avc:  denied  { read } for  pid=19864 comm="glusterfs" name="ip_local_reserved_ports" dev="proc" ino=231783 scontext=system_u:system_r:glusterd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=file


type=AVC msg=audit(1374385670.400:4664): avc:  denied  { open } for  pid=19864 comm="glusterfs" path="/proc/sys/net/ipv4/ip_local_reserved_ports" dev="proc" ino=231783 scontext=system_u:system_r:glusterd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=file


type=SYSCALL msg=audit(1374385670.400:4664): arch=x86_64 syscall=open success=yes exit=EAGAIN a0=7f9214b5a990 a1=0 a2=10 a3=0 items=0 ppid=1 pid=19864 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=glusterfs exe=/usr/sbin/glusterfsd subj=system_u:system_r:glusterd_t:s0-s0:c0.c1023 key=(null)

Hash: glusterfs,glusterd_t,sysctl_net_t,file,read

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-302.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-07-21 07:36:51 EDT
*** Bug 986625 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2013-07-21 07:39:58 EDT
Fixed in git ca8f0241859d1998773435a8744c5b8a8c516f45
Comment 3 Fedora Update System 2013-07-24 10:12:15 EDT
selinux-policy-3.12.1-66.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-66.fc19
Comment 4 Fedora Update System 2013-07-24 20:35:13 EDT
Package selinux-policy-3.12.1-66.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-66.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13543/selinux-policy-3.12.1-66.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-07-26 19:06:09 EDT
selinux-policy-3.12.1-66.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.