Bug 986650 - emacspeak does build due to texinfo
emacspeak does build due to texinfo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: emacspeak (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 05:29 EDT by Petr Pisar
Modified: 2013-07-23 04:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 04:54:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2013-07-21 05:29:07 EDT
emacspeak-37.0-3.fc20 fails to build in the rawhide because of flaws in texinfo source:

make install DESTDIR="" infodir="/builddir/build/BUILDROOT/emacspeak-37.0-3.fc20.noarch/usr/share/info"
make[1]: Entering directory `/builddir/build/BUILD/emacspeak-37.0/info'
makeinfo   emacspeak.texi -o emacspeak.info
./preamble.texi:3: @node seen before @end raggedright
./tts-server.texi:16: raising the section level of @subsection which is too low
./voices.texi:122: warning: node up `What this gives.' in menu `How It All Works.' and in sectioning `Voice Lock' differ
./packages.texi:31: warning: node `Web Browsing' is next for `Browsing Structure' in menu but not in sectioning
./web-browsing.texi:1: warning: node next `Web Browsing' in menu `emacspeak-w3' and in sectioning `Messaging' differ
./web-browsing.texi:1: warning: node `Browsing Structure' is prev for `Web Browsing' in menu but not in sectioning
./web-browsing.texi:1: warning: node up `Web Browsing' in menu `Browsing Structure' and in sectioning `Emacs Packages' differ
./packages.texi:54: warning: node `Editting Program Source' is next for `Messaging' in menu but not in sectioning
./packages.texi:77: warning: node `Development Environment' is next for `Editting Program Source' in menu but not in sectioning
./packages.texi:77: warning: node `Messaging' is prev for `Editting Program Source' in menu but not in sectioning
./packages.texi:109: warning: node `Desktop Management' is next for `Development Environment' in menu but not in sectioning
./packages.texi:109: warning: node `Editting Program Source' is prev for `Development Environment' in menu but not in sectioning
./packages.texi:129: warning: node `Personal Information Management' is next for `Desktop Management' in menu but not in sectioning
./packages.texi:129: warning: node `Development Environment' is prev for `Desktop Management' in menu but not in sectioning
./packages.texi:157: warning: node `Desktop Applications' is next for `Personal Information Management' in menu but not in sectioning
./packages.texi:157: warning: node `Desktop Management' is prev for `Personal Information Management' in menu but not in sectioning
./packages.texi:170: warning: node `Personal Information Management' is prev for `Desktop Applications' in menu but not in sectioning
make[1]: Leaving directory `/builddir/build/BUILD/emacspeak-37.0/info'
make[1]: *** [emacspeak.info] Error 1
make: *** [install] Error 2
Comment 1 Jens Petersen 2013-07-23 04:54:14 EDT
I managed to build emacspeak-38.0 at least now for rawhide.

Note You need to log in before you can comment on or make changes to this bug.