Bug 986652 - missing links under /rhev/datacenter/ although storage and pool are connected (start VM fails)
missing links under /rhev/datacenter/ although storage and pool are connected...
Status: CLOSED DUPLICATE of bug 1026697
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Sergey Gotliv
Aharon Canan
storage
: Triaged
: 989131 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 06:26 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 12:48 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-08 10:15:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: Triaged+


Attachments (Terms of Use)
## Logs rhevm, vdsm, libvirt (4.46 MB, application/x-gzip)
2013-07-21 06:26 EDT, vvyazmin@redhat.com
no flags Details
## Logs superVdsm (4.63 KB, application/x-gzip)
2013-07-21 06:29 EDT, vvyazmin@redhat.com
no flags Details
missing links logs (2.21 MB, application/x-gzip)
2013-12-04 08:27 EST, Elad
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-07-21 06:26:25 EDT
Created attachment 776422 [details]
## Logs rhevm, vdsm, libvirt

Description of problem:
Command “vdsClient -s 0 getVdsStats” succeed run although /rhev/data-center/ folder is empty from links to Storage Pool and Storage Domain

Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS6 environment:

RHEVM: rhevm-3.3.0-0.9.master.el6ev.noarch
VDSM: vdsm-4.12.0-rc1.12.git8ee6885.el6.x86_64
LIBVIRT: libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.355.el6_4.5.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
Create iSCSI DC with 3 hosts
Create 150 VM’s
Power on all those VM’s

Actual results:
1. All VM’s run only on one host, in my case it was on Host-02.
2. After I power off same VM’s and try run them again with changed parameter “Start Running On: Specific host_name“ (Host-01 & Host-03) action failed and VM continue run on same host as described in previous step (Host-02).

After investigation we found following.
1. Following Commands work OK:
vdsClient -s 0 getVdsCaps
vdsClient -s 0 getVdsStats
vdsClient -s 0 getVdsHardwareInfo
vdsClient -s 0 getDeviceList
2. “Vdsmd” daemons in status up, but “SuperVdsmd” daemons down
3. There is no links under /rhev/data-center/ folder (folder /rhev/data-center/ empty)


Expected results:
1. Command “vdsClient -s 0 getVdsStats” should failed if “SuperVdsmd” daemons down or failed run.
2. Command “vdsClient -s 0 getVdsStats” should failed there is no links under /rhev/data-center/ folder (folder /rhev/data-center/ empty)

Impact on user:
Failed run VM’s on specific host.

Workaround:
1. Kill all “Vdsmd” service and run it again with verification that both “Vdsmd” and “SuperVdsmd” running
2. Manually enter in each VM configuration and changed parameter “Start Running On: Specific host_name“

Additional info:

/var/log/ovirt-engine/engine.log

/var/log/vdsm/vdsm.log
Comment 1 vvyazmin@redhat.com 2013-07-21 06:29:51 EDT
Created attachment 776423 [details]
## Logs superVdsm
Comment 3 Allon Mureinik 2013-08-08 03:40:37 EDT
*** Bug 989131 has been marked as a duplicate of this bug. ***
Comment 4 Ayal Baron 2013-09-03 08:11:26 EDT
1. the issue with running the VM is solved by bug 960952
2. Yaniv, are you familiar with Supervdsmd not running issues?
Comment 5 Yaniv Bronhaim 2013-09-08 04:29:12 EDT
How did you come up with:
 "Expected results: 1. Command “vdsClient -s 0 getVdsStats” should failed if 
“SuperVdsmd” daemons down or failed run." ?

If an API call needs supervdsmd service to run and the service is down or after a crash, you will see an exception and restart of vdsm in the log.
Comment 6 Sergey Gotliv 2013-09-08 10:15:05 EDT
I am closing that bug based on comment 4 (the storage part) and comment 5 (the infra part).
Comment 7 Elad 2013-12-04 08:27:05 EST
Created attachment 832646 [details]
missing links logs

I managed to reproduce, attaching logs
Comment 8 Ayal Baron 2013-12-04 08:42:22 EST
Elad, reproduction steps?
Comment 9 Elad 2013-12-04 08:48:02 EST
(In reply to Ayal Baron from comment #8)
> Elad, reproduction steps?

It happened when I blocked connection to storage server which one of the domains in the pool is located on (not the master)
Comment 10 Ayal Baron 2013-12-04 13:40:20 EST
(In reply to Elad from comment #9)
> (In reply to Ayal Baron from comment #8)
> > Elad, reproduction steps?
> 
> It happened when I blocked connection to storage server which one of the
> domains in the pool is located on (not the master)
while it was not active, right?
and then you activated it at some point? and it did not recreate the links?
Comment 11 Elad 2013-12-05 03:25:54 EST
(In reply to Ayal Baron from comment #10)
> (In reply to Elad from comment #9)
> > (In reply to Ayal Baron from comment #8)
> > > Elad, reproduction steps?
> > 
> > It happened when I blocked connection to storage server which one of the
> > domains in the pool is located on (not the master)
> while it was not active, right?
> and then you activated it at some point? and it did not recreate the links?

For focusing on one bug, as this bug is already closed, I answered to your question in https://bugzilla.redhat.com/show_bug.cgi?id=1026697
Comment 12 Sergey Gotliv 2013-12-11 15:14:28 EST

*** This bug has been marked as a duplicate of bug 1026697 ***

Note You need to log in before you can comment on or make changes to this bug.