This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 986660 - bad man page
bad man page
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: dkms (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Simone Caronni
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 07:24 EDT by Dave Love
Modified: 2013-11-30 21:52 EST (History)
4 users (show)

See Also:
Fixed In Version: dkms-2.2.0.3-20.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 14:32:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Define missing SY, YS, OP macros (821 bytes, patch)
2013-11-05 12:56 EST, Brian Behlendorf
no flags Details | Diff

  None (edit)
Description Dave Love 2013-07-21 07:24:53 EDT
Description of problem:

dkms.8 is garbled.  It's specifically missing the command synopses in the
SYNOPSIS and ACTIONS sections.  The rpm source ships only a version
formatted like that, not the source (presumably a GPL violation).

Version-Release number of selected component (if applicable):

2.2.0.3-8
Comment 1 Simone Caronni 2013-07-21 09:14:19 EDT
Hello,

I'm not sure I've understood the problem. In my opinion the manpage is correct, also Debian ships it without patches.

What you were expecting? Different Fedora specific paths instead of /path/to/source-tree] [/path/to/tarball.tar] [/path/to/driver.rpm]?

Thanks,
--Simone
Comment 2 Dave Love 2013-07-22 06:32:45 EDT
The start of the man page display is as follows, which doesn't actually
tell me how to use it due to the missing synopses:

NAME
       dkms - Dynamic Kernel Module Support

SYNOPSIS
DESCRIPTION
       dkms is a framework which allows kernel modules to be dynamically
       built for each kernel on your system in a  simplified  and  orga-
       nized fashion.

ACTIONS
           Adds  a  module/module-version  combination  to  the tree for
           builds  and  installs.   If  module/module-version,  -m  mod-


The Debian version (which comes as troff source) is:

NAME
       dkms - Dynamic Kernel Module Support

SYNOPSIS
       dkms [action] [options] [module/module-version] [/path/to/source-tree]
            [/path/to/tarball.tar] [/path/to/driver.rpm]

DESCRIPTION
       dkms is a framework which allows kernel modules to be dynamically built
       for each kernel on your system in a simplified and organized fashion.

ACTIONS
       add [module/module-version] [/path/to/source-tree]
           [/path/to/tarball.tar]

           Adds a module/module-version combination to the tree for builds and
           installs.   If  module/module-version, -m module/module-version, or
Comment 3 Simone Caronni 2013-07-22 07:16:18 EDT
(In reply to Dave Love from comment #2)
> The Debian version (which comes as troff source) is:
> 
> NAME
>        dkms - Dynamic Kernel Module Support
> 
> SYNOPSIS
>        dkms [action] [options] [module/module-version] [/path/to/source-tree]
>             [/path/to/tarball.tar] [/path/to/driver.rpm]

...which is what I see in dkms-2.2.0.3-8.fc19. Looking into it as only el6 seems to be affected.
Comment 4 Simone Caronni 2013-07-22 08:13:14 EDT
I've checked all builds, all the manpages contain the SYNOPSIS section and everything else. But for some reason on el5 and el6 those sections are not displayed.

Don't know where the bug resides, though; looking into it.
Comment 5 Simone Caronni 2013-07-22 08:55:40 EDT
Ok, figured out, the man version bundled in el5 and el6 is too old to visualize groff tags in man pages with these extensions: .EX/.EE, .SY/.OP/.YS, .UR/.UE, and .MT/.ME.

Looking if there's a way to convert a groff file to an older version.
Comment 6 Dave Love 2013-07-24 07:18:01 EDT
FWIW, the macros are in an-ext.tmac in the groff 1.21 on my Debian system, which
I assume is in Fedora too.
Presumably the page could be patched to add that at the front with older groff.

[Sorry, I don't know why it appeared the page was preformatted in the source
I fetched.]
Comment 7 Brian Behlendorf 2013-11-05 12:48:01 EST
I'm no expert but it appears other older man pages have handled this by adding an explicit macro for '.OP'.  Presumably one could do something similar with '.SY' but I don't see any examples of that.  They've just converted to using the newer syntax.

.de OP
.ie \\n(.$-1 .RI "[\ \fB\\$1\fP" "\\$2" "\ ]"
.el .RB "[\ " "\\$1" "\ ]"
Comment 8 Brian Behlendorf 2013-11-05 12:56:46 EST
Created attachment 819925 [details]
Define missing SY, YS, OP macros

As suggested in a prior comment just define the missing macros at the start of the man page.  These macros were obtained directly from /usr/share/groff/1.21/tmac/an-ext.tmac.
Comment 9 Simone Caronni 2013-11-06 03:49:52 EST
(In reply to Brian Behlendorf from comment #8)
> Created attachment 819925 [details]
> Define missing SY, YS, OP macros
> 
> As suggested in a prior comment just define the missing macros at the start
> of the man page.  These macros were obtained directly from
> /usr/share/groff/1.21/tmac/an-ext.tmac.

Thank you very much, really appreciated! The patch works fine. Adding it to the changes along with the ZFS On Linux patches.
Comment 10 Fedora Update System 2013-11-13 06:58:48 EST
dkms-2.2.0.3-20.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-20.el5
Comment 11 Fedora Update System 2013-11-13 07:00:17 EST
dkms-2.2.0.3-20.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-20.el6
Comment 12 Fedora Update System 2013-11-13 07:01:24 EST
dkms-2.2.0.3-20.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-20.fc18
Comment 13 Fedora Update System 2013-11-13 07:02:08 EST
dkms-2.2.0.3-20.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-20.fc19
Comment 14 Fedora Update System 2013-11-13 07:03:02 EST
dkms-2.2.0.3-20.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-20.fc20
Comment 15 Fedora Update System 2013-11-13 13:48:50 EST
Package dkms-2.2.0.3-20.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing dkms-2.2.0.3-20.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-12084/dkms-2.2.0.3-20.el5
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-11-23 14:32:19 EST
dkms-2.2.0.3-20.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-11-23 14:49:23 EST
dkms-2.2.0.3-20.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-11-23 22:37:10 EST
dkms-2.2.0.3-20.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-11-30 21:51:31 EST
dkms-2.2.0.3-20.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-11-30 21:52:23 EST
dkms-2.2.0.3-20.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.