Bug 986666 - firefox doesn't start
firefox doesn't start
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
19
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 08:11 EDT by Fred New
Modified: 2013-07-26 02:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 02:41:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred New 2013-07-21 08:11:43 EDT
Description of problem:
Firefox fails to start.

Version-Release number of selected component (if applicable):
firefox-22.0-1.fc19.i686

How reproducible:
always

Steps to Reproduce:
1. Upgrade from F18 to F19 on an ancient Pentium 4 system using fedup.
2. Change the session manager so you can log into a graphical session (bug 955779).
3. Log into an LXDE session.
4. Try to start firefox.

Actual results:
No firefox window opens.  If you watch "ps -ef | grep firefox" quickly, you will see something like
fred     19222     1 65 15:00 ?        00:00:09 /usr/lib/firefox/firefox
fred     19350 19222  0 15:00 ?        00:00:00 /usr/lib/firefox/firefox
quickly followed by
fred     19222     1 63 15:00 ?        00:00:09 /usr/lib/firefox/firefox
fred     19350 19222  7 15:00 ?        00:00:00 [firefox] <defunct>

Firefox will try to start more children, but they will all end up <defunct> and then disappear.

Expected results:
A usable browser window.

Additional info:

Starting firefox from a terminal window shows the following repeated error:
[fred@xxx ~]$ firefox

(process:20199): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

(process:20199): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
...
Comment 1 Martin Stransky 2013-07-24 10:09:05 EDT
Can you please ty the steps from:

https://fedoraproject.org/wiki/How_to_debug_Firefox_problems
Comment 2 Fred New 2013-07-24 14:43:57 EDT
Thanks, that helped. I discovered that the problem is being caused by the Estonian ID (smart) card add-on. Disabling this add-on allows Firefox to start. I didn't notice in the above link how I might further debug the add-on. I don't see any new dump files anywhere.
Comment 3 Fred New 2013-07-25 14:54:41 EDT
So this obviously isn't a firefox problem - you may close this. I'll see what I can determine using gdb.

Note You need to log in before you can comment on or make changes to this bug.