Bug 986668 - [engine] Display type is not inherited correctly from templates
[engine] Display type is not inherited correctly from templates
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Frantisek Kobzik
Tareq Alayan
virt
: ZStream
Depends On:
Blocks: 996125
  Show dependency treegraph
 
Reported: 2013-07-21 08:26 EDT by Ido Begun
Modified: 2015-09-22 09 EDT (History)
11 users (show)

See Also:
Fixed In Version: is10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 996125 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (1.87 MB, text/x-log)
2013-07-21 08:26 EDT, Ido Begun
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17336 None None None Never

  None (edit)
Description Ido Begun 2013-07-21 08:26:00 EDT
Created attachment 776440 [details]
engine.log

Description of problem:
In API, default display type is applied to a new VM when created from a template with a different display type.

Version-Release number of selected component (if applicable):
rhevm-3.2.1-0.39.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create VM with display type (vnc in 3.2) different from default (spice in 3.2):
<vm>
<name>vnc-orig</name>
<cluster><name>XXX</name></cluster>
<display><type>vnc</type></display>
<template><name>Blank</name></template>
</vm>

2. Create template from VM:
<template>
<name>vnc-temp</name>
<vm id="XXX"/>
</template>

(at this point template should have the same display type as the original VM)

3. Create VM from template:
<vm>
<name>vnc-api-clone</name>
<cluster><name>XXX</name></cluster>
<template><name>vnc-temp</name></template>
</vm>

Actual results:
Second VM's display type is the same as default (spice in 3.2)

Expected results:
Second VM's display type should be the same the original VM's.

Additional info:
Reproducible in 3.3 as well (with vnc being default).
I wasn't able to reproduce this using webadmin.
Comment 1 Frantisek Kobzik 2013-07-31 05:12:13 EDT
merged u/s: f5e6e457ad00ab0a6aeabe7e4386b26e8bfbc195
Comment 4 David Botzer 2013-08-27 10:00:09 EDT
I wasnt able to reproduce this via webadmin
3.3/is11 (also at 3.2/sf20.1)
Display Is correct at all sides

Please advise,
Comment 5 Frantisek Kobzik 2013-08-29 02:59:13 EDT
Hi David,
I believe this bug shouldn't be reproducable in is11/sf20 since the patch has been merged in these builds.
Comment 6 Itamar Heim 2014-01-21 17:21:33 EST
Closing - RHEV 3.3 Released
Comment 7 Itamar Heim 2014-01-21 17:26:54 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.