Bug 986671 - Crash in SVN view in on_row_activated, fix attached.
Crash in SVN view in on_row_activated, fix attached.
Status: CLOSED DUPLICATE of bug 1022230
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 09:10 EDT by Gilboa Davara
Modified: 2013-10-25 10:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 10:17:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vcview crash fix. (455 bytes, patch)
2013-07-21 09:10 EDT, Gilboa Davara
no flags Details | Diff

  None (edit)
Description Gilboa Davara 2013-07-21 09:10:52 EDT
Created attachment 776451 [details]
vcview crash fix.

Description:
When opening multiple files in SVN mode, meld crashes after the 3'rd file.
Attached fix taken from upstream head and OK'ed by developer [1]

Version-Release number of selected component (if applicable):
meld-1.7.3-1.fc19.noarch

- Gilboa
[1] https://mail.gnome.org/archives/meld-list/2013-June/msg00035.html
Comment 1 Gilboa Davara 2013-07-21 09:11:42 EDT
Missing callstack:

Traceback (most recent call last):
  File "/usr/share/meld/meld/vcview.py", line 576, in on_row_activated
    self.run_diff( [path] )
  File "/usr/share/meld/meld/vcview.py", line 612, in run_diff
    [], [(os.path.basename(path), path)])[1][0]
IndexError: list index out of range
Traceback (most recent call last):
  File "/usr/share/meld/meld/vcview.py", line 576, in on_row_activated
    self.run_diff( [path] )
  File "/usr/share/meld/meld/vcview.py", line 612, in run_diff
    [], [(os.path.basename(path), path)])[1][0]
IndexError: list index out of range
Comment 2 Gilboa Davara 2013-10-25 05:34:02 EDT
Fixed by current version of meld.
Bug can be fixed.
Comment 3 Christoph Wickert 2013-10-25 10:17:43 EDT

*** This bug has been marked as a duplicate of bug 1022230 ***

Note You need to log in before you can comment on or make changes to this bug.