Bug 986683 - libsoup crashes java-1.7.0-openjdk when launching CrashPlan GUI
libsoup crashes java-1.7.0-openjdk when launching CrashPlan GUI
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
19
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 11:22 EDT by Joshua Coats
Modified: 2014-04-30 14:18 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 01:36:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hs_error.log from crashed openjdk server (68.13 KB, text/x-log)
2013-07-22 23:41 EDT, Joshua Coats
no flags Details

  None (edit)
Description Joshua Coats 2013-07-21 11:22:14 EDT
Description of problem:
Since upgrading to Fedora 19, CrashPlan's GUI won't launch, and fails with the following error in CrashPlan's log:

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x4d8a30de, pid=5077, tid=3064032064
#
# JRE version: 7.0_25
# Java VM: OpenJDK Server VM (23.7-b01 mixed mode linux-x86 )
# Problematic frame:
# C  [libsoup-2.4.so.1+0x560de]  soup_session_feature_detach+0x1e
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/jvm-5077/hs_error.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#


Version-Release number of selected component (if applicable):
java-1.7.0-openjdk-1.7.0.25-2.3.10.4.fc19.i686
libsoup-2.42.2-1.fc19.i686
CrashPlan 3.5.3


How reproducible:
This crash occurs every time I try to open CrashPlan.


Steps to Reproduce:
I haven't reproduced it on another system, but I would assume that to reproduce it, you could:
1. install java-1.7.0-openjdk-1.7.0.25-2.3.10.4.fc19.i686 and libsoup-2.42.2-1.fc19.i686
2. download CrashPlan
3. try to launch CrashPlan

Actual results:
java-1.7.0-openjdk crashes

Expected results:
it shouldn't

Additional info:
Comment 1 Joshua Coats 2013-07-21 11:23:18 EDT
Additionally, it looks like Ubuntu has experienced a similar problem (https://bugs.launchpad.net/ubuntu/+source/openjdk-6/+bug/712119) but unfortunately the workaround of uninstalling the offending package isn't an option here.
Comment 2 Deepak Bhole 2013-07-22 09:37:58 EDT
Do you have the hr_err log file, and if so, can you please post it?
Comment 3 Joshua Coats 2013-07-22 23:41:02 EDT
Created attachment 777150 [details]
hs_error.log from crashed openjdk server
Comment 4 Joshua Coats 2013-07-22 23:41:49 EDT
(In reply to Deepak Bhole from comment #2)
> Do you have the hr_err log file, and if so, can you please post it?

Attached the hs_error.log from this crash.
Comment 5 Deepak Bhole 2013-07-23 13:42:40 EDT
Thanks. This looks like it is originating from JNI code in swt and I am going to re-assign it to Eclipse as there is nothing the JDK can do to address this.
Comment 6 Alexander Kurtakov 2013-07-24 01:36:04 EDT
This is using swt 4.2 built by some thirdparty. swt.jar in eclipse-swt rpm as shipped with Fedora 19 contains a patch to fix this.
There is nothing we can do about the app you're using as they need to update their swt version to a new one compatible with latest webkit. You can also try to update the swt.jar in the app with the our swt.jar which would most probably work.
With that said I'm closing as cantfix as there is not much we can do about fixing CrashPlan.
Comment 7 Joshua Coats 2013-07-24 02:59:41 EDT
Just replaced the swt.jar with Fedora's, and it works fine now. Thanks!
Comment 8 Jason Merrill 2014-01-08 13:43:18 EST
This workaround isn't doing the trick for me in Fedora 20, unfortunately.  Any ideas?
Comment 9 djschaap 2014-02-03 00:39:27 EST
This may not be a Fedora issue, but adding a workaround in the hope that it helps somebody:

1) Edit /usr/local/crashplan/bin/CrashPlanDesktop
2) Add "-Dorg.eclipse.swt.browser.DefaultType=mozilla" just before "-classpath" on the last line
3) Run CrashPlanDesktop

Found this here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=405786
Comment 10 Jason Merrill 2014-02-03 11:50:22 EST
That fixed the problem for me, thanks.  I also needed to add a file containing 

fs.inotify.max_user_watches=1048576

to /etc/sysctl.d; without that I was unable to unlock the screensaver because CrashPlan was eating of the watches.
Comment 11 Gerald Cox 2014-04-30 14:18:18 EDT
I sent a note to the Crashplan folks and they recommend the same fix... but in a different location.  Here is the URL:

https://support.code42.com/CrashPlan/Latest/Troubleshooting/CrashPlan_Client_Closes_In_Some_Linux_Installations

Their solution is:


    Edit the run.conf file in your CrashPlan app installation directory
    Default location: /usr/local/crashplan/bin/
    Navigate to the end of the GUI_JAVA_OPTS section
    Add this line, inside the quotes:
    -Dorg.eclipse.swt.browser.DefaultType=mozilla
    Example:

SRV_JAVA_OPTS="-Dfile.encoding=UTF-8 -Dapp=CrashPlanService -DappBaseName=CrashPlan -Xms20m -Xmx512m -Djava.net.preferIPv4Stack=true -Dsun.net.inetaddr.ttl=300 -Dnetworkaddress.cache.ttl=300 -Dsun.net.inetaddr.negative.ttl=0 -Dnetworkaddress.cache.negative.ttl=0 -Dc42.native.md5.enabled=false"
GUI_JAVA_OPTS="-Dfile.encoding=UTF-8 -Dapp=CrashPlanDesktop -DappBaseName=CrashPlan -Xms20m -Xmx512m -Djava.net.preferIPv4Stack=true -Dsun.net.inetaddr.ttl=300 -Dnetworkaddress.cache.ttl=300 -Dsun.net.inetaddr.negative.ttl=0 -Dnetworkaddress.cache.negative.ttl=0 -Dc42.native.md5.enabled=false -Dorg.eclipse.swt.browser.DefaultType=mozilla"

    Save the file
    The CrashPlan app should launch properly

Note You need to log in before you can comment on or make changes to this bug.