Bug 986690 - [KDE] Cannot use dead keys in some locales
[KDE] Cannot use dead keys in some locales
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 12:09 EDT by Ricardo Fernández Pascual
Modified: 2015-07-13 13:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-18 09:01:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricardo Fernández Pascual 2013-07-21 12:09:32 EDT
* Description of problem: Dead keys don't work if LC_ALL contains a value no recognized by Xlib. I suspected that the problem was related to the locale thanks to the following message that appears in the console:

I18N: X Window System doesn't support locale "en_DK.utf8"

Note that other X programs (like xterm) emit a similar warning, but they work all right anyway. Most X programs (eg, GTK and QT programs) do not emit the warning and work perfectly.

* How reproducible: Always

* Steps to Reproduce:
1 - Set LC_ALL to either "en_DK.utf8" or "en_US.utf8"
2 - Start oowriter
3 - Try to use any dead key or the compose key.

* Actual results: Dead keys do not work when LC_ALL="en_DK.utf8". They work with LC_ALL="en_US.utf8"

* Expected results: LC_ALL should not affect at all the behaviour of the keyboard in any X program.

* Additional info: This worked perfectly in Fedora 17
Comment 1 Caolan McNamara 2013-07-30 06:36:15 EDT
As far as I can tell it seems to work fine in F19 with unknown locales. en_DK.utf8 is known to X in F-19, but aa_ER.utf8@saaho isn't and with that set my compose key works fine too.
Comment 2 Ricardo Fernández Pascual 2013-08-05 06:22:07 EDT
Unfortunately, this still happens in Fedora 19 (upgraded via fedup). Also, I still get the message “I18N: X Window System doesn't support locale "en_DK.utf8"”.

A minor difference is that the relevant environment variable is LANG instead of LC_ALL (LC_ALL is not defined in my system now).

Let me know if I can provide any more information for fixing this problem. I see two issues:

    1: en_DK.utf8 is not a known locale to Xlib, at least in my system.
    2: LANG and LC_ALL affect the keyboard handling in libreoffice, which they shouldn't do, in my opinion.
Comment 3 Caolan McNamara 2013-08-05 10:01:44 EDT
and what desktop environment are you using, I see absolutely no problem here locally.
Comment 4 Ricardo Fernández Pascual 2013-08-05 12:08:41 EDT
I am using KDE. Sorry for not telling that before, but I didn't expect that it was relevant. 

Indeed, it is relevant. I have just tried in a Gnome session and it works there. 

I am especially surprised of the fact that I get the “…doesn't support locale…” under KDE but not under Gnome.
Comment 5 Caolan McNamara 2013-08-06 04:24:50 EDT
aha, and one last thing, this is with libreoffice-kde installed, i.e.
rpm -q libreoffice-kde
Comment 6 Ricardo Fernández Pascual 2013-08-06 05:39:33 EDT
Yes,  libreoffice-kde-4.1.0.4-1.fc19.x86_64 is installed.
Comment 7 Lukáš Tinkl 2013-08-07 12:30:41 EDT
We know about this bug, something rotten in Qt :/

*** This bug has been marked as a duplicate of bug 968367 ***
Comment 8 Rex Dieter 2013-08-07 12:39:38 EDT
Hrm, several upstream comments in 
https://bugs.kde.org/show_bug.cgi?id=320423
claim this is still a problem with qt-4.8.5, re-opening.
Comment 9 Rex Dieter 2013-08-07 12:40:19 EDT
bleh, added comment in the wrong place sorry.

*** This bug has been marked as a duplicate of bug 968367 ***
Comment 10 Ricardo Fernández Pascual 2013-08-09 08:50:28 EDT
Sorry, I really don't think that this is a duplicate of bug 968367.

The problem described in this bug is related to locales (it is triggered by changing the LANG or LC_ALL environment variables, not the keyboard layout). Also, it affects only programs that do not use qt (e.g.: LibreOffice), but only while running under a Kde session.
Comment 11 Fedora End Of Life 2015-01-09 17:12:59 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 12 Fedora End Of Life 2015-02-18 09:01:32 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.