Bug 986698 - cronie-1.4.11-1.fc20 packaging has broken scriptlets
cronie-1.4.11-1.fc20 packaging has broken scriptlets
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 13:43 EDT by Michal Jaegermann
Modified: 2013-08-13 05:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-13 05:01:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2013-07-21 13:43:57 EDT
Description of problem:

The current package from rawhide updates for cronie sports the following scriplets:

postinstall scriptlet (using /bin/sh):
# run after an installation
%systemd_post crond.service
preuninstall scriptlet (using /bin/sh):
# run before a package is removed
%systemd_preun crond.service
postuninstall scriptlet (using /bin/sh):
# run after a package is removed
%systemd_postun_with_restart crond.service

As they are run by /bin/sh attempts to use these, unsurprisingly, results in:

/var/tmp/rpm-tmp.Wwb2pw: line 2: fg: no job control
warning: %post(cronie-1.4.11-1.fc20.x86_64) scriptlet failed, exit status 1

Version-Release number of selected component (if applicable):
cronie-1.4.11-1.fc20

Additional info:
See also the same issue for nscd in bug 983760
Comment 1 Marcela Mašláňová 2013-07-22 04:02:12 EDT
Thanks for this report. I remember removing systemd-unit some time ago, because they shouldn't be needed anymore according to guidelines. I opened a ticket for fpc https://fedorahosted.org/fpc/ticket/318
Comment 2 Marcela Mašláňová 2013-08-13 05:01:19 EDT
I fixed it by adding BR: systemd, which is recommended solution.

Note You need to log in before you can comment on or make changes to this bug.