Bug 98670 - Wanted: Package selection + update start via command line
Wanted: Package selection + update start via command line
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-07 08:33 EDT by Toralf
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 15:56:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2003-07-07 08:33:37 EDT
Description of problem:
Another note related to bug 98669: I'd really also like to be able to start
installation directly based on command line arguments. I'm thinking about a mode
where I could say something like

redhat-config-packages --add "Development Tools" 

in order to add packages in group "Development Tools" to a system, instead of
starting up, selecting the group via GUI and clicking "Update". For this mode to
be useful, no confirmations at all should be required to start the install
process, and the utility should perhaps also exit automatically on completion.


Version-Release number of selected component (if applicable):
1.1.8-1, 1.1.9-1
Comment 1 Toralf 2003-07-16 07:13:35 EDT
It turns out that yum (http://linux.duke.edu/projects/yum/) contains most of the
functionality I want, so maybe I'll use that instead. I'd really like to see
something like this in a standard (i.e. distributed on Red Hat CDs) tool,
though. Also, maybe the development efforts could be integrated?
Comment 2 Toralf 2003-09-03 10:24:09 EDT
Another thought: Maybe you could support anaconda kickstart files, or the
relevant sections of these, i.e. allow e.g.

redhat-config-packages --kickstart ks.cfg

- which would install all groups or packages listed in %packages that aren't
already installed, and possibly also update the ones that are if a new version
is present on the source tree. Without asking any questions, of course.

Installation source might be taken from "url" option in kickstart file, but I
wouldn't mind using specifying it using "--tree", either.

Kickstart files of course have a lot of information that isn't relevant here,
but it would be really nice to be able to use the same information source for
fresh installs and live updates.
Comment 3 Jeremy Katz 2005-07-29 15:56:35 EDT
yum is the way to do this

Note You need to log in before you can comment on or make changes to this bug.