Bug 986770 - "service iptables stop" flushes rules but "service iptables start" does not reload them
"service iptables stop" flushes rules but "service iptables start" does not r...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 23:58 EDT by Murray McAllister
Modified: 2015-01-04 17:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 05:53:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Murray McAllister 2013-07-21 23:58:33 EDT
Description of problem:
On up-to-date Fedora 19, service iptables stop flushes rules (as shown with iptables -L) but service iptables start does not reload them. No errors are printed to the console.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. iptables -L
2. service iptables stop
3. service iptables start

Actual results:
rules not reloaded

Expected results:
rules reloaded. If I am not suppose to be using service (due systemd) or iptables (due firewalld), could some error message or pointer to the docs be shown when attempting to use service and iptables?

Additional info:
Comment 1 Thomas Woerner 2013-07-22 07:21:16 EDT
Which firewall system are you using?

The default since Fedora 18 is firewalld. For information on firewalld, please have a look at

https://fedoraproject.org/wiki/FirewallD

If you want to use your own static firewall rules with the iptables and ip6tables services, install iptables-services and disable firewalld and enable iptables and ip6tables:

yum install iptables-services
systemctl mask firewalld.service
systemctl enable iptables.service
systemctl enable ip6tables.service

Use /etc/sysconfig/iptables and /etc/sysconfig/ip6tables for your static firewall rules. These will be loaded with service iptables start and service ip6tables start.

Note: The package iptables and iptables-services do not provide firewall rules for use with the services. The services are available for compatibility and people that want to use their own firewall rules. You can install and use system-config-firewall to create rules with the services though.

After creating rules for use with the services stop firewalld and start the iptables and ip6tables services:

 systemctl stop firewalld.service
 systemctl start iptables.service
 systemctl start ip6tables.service
Comment 2 Murray McAllister 2013-07-22 22:52:55 EDT
(In reply to Thomas Woerner from comment #1)
> Which firewall system are you using?

Sorry, seems this is all just user error (coming from RHEL 5) :(

Using the commands you provided I find I am using firewalld. The iptables services are not active, and I have no /etc/sysconfig/iptables files.

Thanks for the quick reply and pointers to information!
Comment 3 Murray McAllister 2013-07-22 22:54:16 EDT
(Also, I am not using custom rules, just whatever is used with the default install.)
Comment 4 Thomas Woerner 2013-07-23 05:53:42 EDT
Closing as NOT A BUG due to comment 2

Note You need to log in before you can comment on or make changes to this bug.