Bug 986772 - clutter is spamming my /var/log/messages with huge numbers of "Clutter-CRITICAL" errors
clutter is spamming my /var/log/messages with huge numbers of "Clutter-CRITIC...
Status: CLOSED DUPLICATE of bug 982550
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 00:39 EDT by Jonathan Kamens
Modified: 2013-08-19 12:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 12:09:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2013-07-22 00:39:29 EDT
Cinnamon is spamming my X session logs, and therefore /var/log/messages, with huge numbers of log entries like this:

Jul 21 01:18:01 jik2 /etc/gdm/Xsession[11774]: (cinnamon:12009): Clutter-CRITICAL **: clutter_text_get_editable: assertion `CLUTTER_IS_TEXT (self)' failed
Jul 21 01:18:01 jik2 /etc/gdm/Xsession[11774]: (cinnamon:12009): Clutter-CRITICAL **: clutter_text_get_text: assertion `CLUTTER_IS_TEXT (self)' failed
Jul 21 01:18:01 jik2 /etc/gdm/Xsession[11774]: (cinnamon:12009): Clutter-CRITICAL **: clutter_text_set_text: assertion `CLUTTER_IS_TEXT (self)' failed

These repeat over and over. When I say "huge", I mean like to the tune of 21MB of log messages per hour, which is a hefty amount of disk space to be wasting, not to mention impacting my performance because of all the CPU and disk I/O required to process these log messages.

Once it starts, it doesn't seem to stop until I log out and log back in. I have no idea what causes it to start happening.
Comment 1 Tibbs Brookside 2013-08-19 11:23:23 EDT
just to say that i'm seeing the same thing on f19 with all the latest updates. i'm also experiencing the momentary freezes as reported in:
http://forums.linuxmint.com/viewtopic.php?f=218&t=127603
Comment 2 leigh scott 2013-08-19 12:09:01 EDT

*** This bug has been marked as a duplicate of bug 982550 ***
Comment 3 leigh scott 2013-08-19 12:11:07 EDT
I don't have any clutter warnings here.

[leigh@main-pc ~]$ journalctl -b | grep Clutter-CRITICAL | wc -l
0

Note You need to log in before you can comment on or make changes to this bug.