This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 986829 - system-config-network error
system-config-network error
Status: CLOSED DUPLICATE of bug 950988
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.9
i386 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks: 1049888
  Show dependency treegraph
 
Reported: 2013-07-22 04:13 EDT by david
Modified: 2014-03-12 09:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-12 09:14:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david 2013-07-22 04:13:52 EDT
出现一个未解决的异常。这极可能是一个程序错误,请将其崩溃组合码转储入一个文件,然                                                                                                  后在 https://bugzilla.redhat.com/bugzilla 提交一份关于 system-config-network 的                                                                                                  详细错误报告。
Component: system-config-network
Version: 1.3.99.21
Summary: TB /usr/lib/python2.4/site-packages/rhpl/genClass.py:217:_objToStr:Unic                                                                                                  odeDecodeError: 'ascii' codec can't decode byte 0xe7 in position 0: ordinal not                                                                                                   in range(128)
Traceback (most recent call last):
  File "/usr/sbin/system-config-network-tui", line 230, in ?
    loadConfig(screen)
  File "/usr/sbin/system-config-network-tui", line 136, in loadConfig
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 510                                                                                                  , in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 363                                                                                                  , in load
    self.updateFromSystem()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 269                                                                                                  , in updateFromSystem
    log.log(5, str(self))
  File "/usr/lib/python2.4/site-packages/rhpl/genClass.py", line 550, in __str__
    return GenClass.__str__(self)
  File "/usr/lib/python2.4/site-packages/rhpl/genClass.py", line 179, in __str__
    return self._objToStr(parentStr)
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 328                                                                                                  , in _objToStr
    retstr += dev._objToStr("HardwareList.%s.%s" % (dev.Type,
  File "/usr/lib/python2.4/site-packages/rhpl/genClass.py", line 217, in _objToS                                                                                                  tr
    retstr += "%s.%s=%s\n" % (parentStr, child, str(val))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe7 in position 0: ordinal                                                                                                   not in range(128)

> /usr/lib/python2.4/site-packages/rhpl/genClass.py(217)_objToStr()
-> retstr += "%s.%s=%s\n" % (parentStr, child, str(val))
Comment 2 Harald Hoyer 2014-03-12 09:14:58 EDT

*** This bug has been marked as a duplicate of bug 950988 ***

Note You need to log in before you can comment on or make changes to this bug.