Bug 986874 - [abrt] virt-manager-0.9.5-1.fc18: dequeue_pending_request: Process /usr/bin/python2.7 was killed by signal 6 (SIGABRT)
[abrt] virt-manager-0.9.5-1.fc18: dequeue_pending_request: Process /usr/bin/p...
Status: CLOSED DUPLICATE of bug 889771
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
abrt_hash:e5bcc1ffc999e7bfc490fa96a7e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 05:56 EDT by Allan Poulsen
Modified: 2013-07-29 07:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 07:01:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (78.67 KB, text/plain)
2013-07-22 05:56 EDT, Allan Poulsen
no flags Details
File: cgroup (129 bytes, text/plain)
2013-07-22 05:56 EDT, Allan Poulsen
no flags Details
File: core_backtrace (6.06 KB, text/plain)
2013-07-22 05:56 EDT, Allan Poulsen
no flags Details
File: dso_list (19.84 KB, text/plain)
2013-07-22 05:57 EDT, Allan Poulsen
no flags Details
File: environ (1.84 KB, text/plain)
2013-07-22 05:57 EDT, Allan Poulsen
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-22 05:57 EDT, Allan Poulsen
no flags Details
File: maps (96.76 KB, text/plain)
2013-07-22 05:57 EDT, Allan Poulsen
no flags Details
File: open_fds (2.21 KB, text/plain)
2013-07-22 05:57 EDT, Allan Poulsen
no flags Details
File: proc_pid_status (969 bytes, text/plain)
2013-07-22 05:57 EDT, Allan Poulsen
no flags Details

  None (edit)
Description Allan Poulsen 2013-07-22 05:56:41 EDT
Description of problem:
I tried to run a wireshark within and outside of the virtual guest at the same time. Both must have depleated the available memory, causing this crash.

Version-Release number of selected component:
virt-manager-0.9.5-1.fc18

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        python /usr/share/virt-manager/virt-manager.py
crash_function: dequeue_pending_request
executable:     /usr/bin/python2.7
kernel:         3.9.9-201.fc18.x86_64
runlevel:       N 5
uid:            10004
var_log_messages: Jul 22 11:38:14 alp-desk1 abrt[13954]: Saved core dump of pid 21444 (/usr/bin/python2.7) to /var/tmp/abrt/ccpp-2013-07-22-11:38:11-21444 (424685568 bytes)
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 dequeue_pending_request at xcb_io.c:177
 #6 XGetWindowProperty at GetProp.c:69
 #7 fetch_net_wm_check_window at gdkevents-x11.c:2671
 #8 gdk_x11_screen_supports_net_wm_hint at gdkevents-x11.c:2852
 #9 gdk_x11_window_set_user_time at gdkwindow-x11.c:3741
 #10 setup_toplevel_window at gdkwindow-x11.c:637
 #11 _gdk_window_impl_new at gdkwindow-x11.c:821
 #12 gdk_window_new at gdkwindow.c:1456
 #13 gtk_window_realize at gtkwindow.c:4843
 #18 gtk_widget_realize at gtkwidget.c:3561
Comment 1 Allan Poulsen 2013-07-22 05:56:47 EDT
Created attachment 776835 [details]
File: backtrace
Comment 2 Allan Poulsen 2013-07-22 05:56:52 EDT
Created attachment 776836 [details]
File: cgroup
Comment 3 Allan Poulsen 2013-07-22 05:56:56 EDT
Created attachment 776837 [details]
File: core_backtrace
Comment 4 Allan Poulsen 2013-07-22 05:57:01 EDT
Created attachment 776838 [details]
File: dso_list
Comment 5 Allan Poulsen 2013-07-22 05:57:05 EDT
Created attachment 776839 [details]
File: environ
Comment 6 Allan Poulsen 2013-07-22 05:57:10 EDT
Created attachment 776840 [details]
File: limits
Comment 7 Allan Poulsen 2013-07-22 05:57:14 EDT
Created attachment 776841 [details]
File: maps
Comment 8 Allan Poulsen 2013-07-22 05:57:19 EDT
Created attachment 776842 [details]
File: open_fds
Comment 9 Allan Poulsen 2013-07-22 05:57:23 EDT
Created attachment 776843 [details]
File: proc_pid_status
Comment 10 Cole Robinson 2013-07-25 17:35:02 EDT
Is this reliably reproducible? Are you running on kde by any chance? I've seen similar reports like this from oxygen theme users:

https://bugzilla.redhat.com/show_bug.cgi?id=889771
Comment 11 Allan Poulsen 2013-07-29 05:58:35 EDT
Yes you are right - I am running with KDE on FC17, and the oxygen theme. But I also see strange GTK behaviour when running with the Raleigh theme.
Comment 12 Cole Robinson 2013-07-29 07:01:41 EDT
Not sure about that other theme, maybe this is just some generic gtk-on-kde issue. Duping to the similar report.

*** This bug has been marked as a duplicate of bug 889771 ***

Note You need to log in before you can comment on or make changes to this bug.