Bug 986933 - Add APP_UUID to EAP/EWS cartridge processes
Add APP_UUID to EAP/EWS cartridge processes
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 08:55 EDT by Brenton Leanhardt
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
An OPENSHIFT_APP_UUID variable has been added to the process command line for the JBoss EAP and JBoss EWS cartridges. This allows JBoss ON to group gears running within the same application.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:20:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-07-22 08:55:50 EDT
Description of problem:

This functionality was committed upstream as part of https://github.com/openshift/origin-server/pull/2809.  This is needed so that JON can group gears running within the same application.
Comment 2 Brenton Leanhardt 2013-07-22 08:58:38 EDT
The upstream commit:

commit c073c4ab4d9786e60d8a360732c1aed4569b1230
Author: William DeCoste <bdecoste@gmail.com>
Date:   Tue Jun 11 03:48:20 2013 -0700

    add APP_UUID to process
Comment 5 Gaoyun Pei 2013-07-23 02:42:39 EDT
verify this on puddle 1.2/2013-07-22.2

After creating jbosseap-6.0/jbossews-1.0/jbossews-2.0 app, ssh into apps, check the java process of the gears.

jbossews-1.0 app:
524      26479 26357  0 23:19 ?        00:00:03 /etc/alternatives/java_sdk_1.7.0/bin/java -Xmx256m -XX:MaxPermSize=102m -XX:+AggressiveOpts -DOPENSHIFT_APP_UUID=51ee207fa4212433080000e4 -Djava..

jbossews-2.0 app:
522      20729 20607  0 23:09 ?        00:00:06 /etc/alternatives/java_sdk_1.7.0/bin/java -Xmx256m -XX:MaxPermSize=102m -XX:+AggressiveOpts -DOPENSHIFT_APP_UUID=51ee1df1a4212433080000cf -Djava......

jbosseap-6.0 app:
526      12171 11999 24 23:40 ?        00:00:10 /usr/lib/jvm/jre-1.7.0/bin/java -D[Standalone] -server -XX:+UseCompressedOops -XX:+TieredCompilation -Xmx256m -XX:MaxPermSize=102m -XX:+AggressiveOpts -Dorg.apache.tomcat.util.LOW_MEMORY=true -DOPENSHIFT_APP_UUID=51ee2569a421243e8a000274 -Dorg.jboss.resolver.warning=true...
Comment 8 errata-xmlrpc 2013-08-05 13:20:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.