Bug 986942 - Missing application icon
Missing application icon
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: backintime (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 09:13 EDT by Raphael Groner
Modified: 2013-07-24 05:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 986839
Environment:
Last Closed: 2013-07-24 05:51:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael Groner 2013-07-22 09:13:00 EDT
There's no application icon available. It seems that gtk-save is not accessible in Xfce environment.


+++ This bug was initially created as a clone of Bug #986839 +++

Description of problem:
I miss some icons: 
- Back In Time, Back In Time (root)
- Terminal
- Administration (menu)
- Multimedia menu: Volume Control, PulseAudio Volume
- Application finder
- maybe others… (not installed)

Version-Release number of selected component (if applicable):
elementary-icon-theme-3.0-1.fc19.noarch

How reproducible:
yes

Steps to Reproduce:
1. install elementary-icon-theme-3.0-1.fc19.noarch
2. select elementary as the icon theme to use in Xfce
3.

Actual results:
missing/empty icons

Expected results:
nice icons everywhere

Additional info:

--- Additional comment from hannes on 2013-07-22 10:45:43 CEST ---

Hi Raphael,

that's why I refused to update the package, but the bugreporter and the new packager only cared about Gnome.
I would suggest to switch to https://github.com/shimmerproject/elementary-xfce
I already prepared a package and will try to get it into fedora.

Hope this helps

Johannes

--- Additional comment from Raphael Groner on 2013-07-22 12:26:41 CEST ---

Hi Hannes,

thanks for the fast response.

Yeah, this issue is somehow strange.

$ find / -name gtk-save.* 2>/dev/null
/usr/share/icons/gnome/48x48/actions/gtk-save.png
/usr/share/icons/gnome/256x256/actions/gtk-save.png
/usr/share/icons/gnome/16x16/actions/gtk-save.png
/usr/share/icons/gnome/24x24/actions/gtk-save.png
/usr/share/icons/gnome/22x22/actions/gtk-save.png
/usr/share/icons/gnome/32x32/actions/gtk-save.png
$ grep Icon /usr/share/applications/backintime-gnome.desktop
Icon=gtk-save
$

Should I report that individually, e.g. as a new separate bug to backintime?

--- Additional comment from Raphael Groner on 2013-07-22 14:14:14 CEST ---

(In reply to hannes from comment #1)
…
> I would suggest to switch to
> https://github.com/shimmerproject/elementary-xfce
> I already prepared a package and will try to get it into fedora.

I would suggest, give it a chance. It should not be too difficult. Maybe take the following PKGBUILD as a template.

https://aur.archlinux.org/packages/el/elementary-xfce-icons/PKGBUILD
Comment 1 Raphael Groner 2013-07-24 05:51:12 EDT
Works for me with elementary-xfce-icon-theme (planned package request [*]).

[*] https://bugzilla.redhat.com/show_bug.cgi?id=986839#c4

Note You need to log in before you can comment on or make changes to this bug.