Bug 986947 - RFE firewalld: add service for dhcp/proxy-dhcp server
RFE firewalld: add service for dhcp/proxy-dhcp server
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
19
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 09:25 EDT by Stefan Assmann
Modified: 2013-08-03 20:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: firewalld-0.3.4-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-03 20:09:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Assmann 2013-07-22 09:25:53 EDT
Description of problem:
Please add a service file for dhcp-server
dhcp: port 67 udp
proxydhcp: port 4011 udp

Proxydhcp is useful for pxe environments.
http://en.wikipedia.org/wiki/Preboot_Execution_Environment

Version-Release number of selected component (if applicable):
firewalld-0.3.3-2.fc19.noarch
Comment 1 Jiri Popelka 2013-07-25 07:13:55 EDT
Hi Stefan,

(In reply to Stefan Assmann from comment #0)
> Please add a service file for dhcp-server
> dhcp: port 67 udp

In bug #917866, comment #1 I wrote:
I don't think we need the same for DHCPv4 server because ISC DHCP(v4) makes use of raw sockets which bypass firewall completely, see
https://deepthought.isc.org/article/AA-00378/0/Why-does-DHCP-use-raw-sockets.html

> proxydhcp: port 4011 udp

Yes, I can add it, but are you sure it's actually needed and it's not the same case as pure DHCPv4 ?
Comment 2 Stefan Assmann 2013-07-25 07:52:40 EDT
Hi Jiri,

in my testing for PXE it actually makes a difference, I have
# firewall-cmd --list-ports
69/udp 67/udp 4011/udp

67 is for dhcp
69 is for tftp
4011 is for proxy-dhcp

If I remove port 67 and I try to PXE boot a client exactly nothing happens.
And if I remove 4011 it breaks as well.

Note: I'm using dnsmasq + tftp here. Maybe it's different for dhcpd?

Alternatively, we could name it pxe-server instead of dhcp-server. What do you think?
Comment 3 Jiri Popelka 2013-07-25 08:03:16 EDT
(In reply to Stefan Assmann from comment #2)
> If I remove port 67 and I try to PXE boot a client exactly nothing happens.
> And if I remove 4011 it breaks as well.
> Note: I'm using dnsmasq + tftp here. Maybe it's different for dhcpd?

Ok, thanks, that's sufficient.
It looks like we need both of them then.
Comment 5 Fedora Update System 2013-07-30 15:14:15 EDT
firewalld-0.3.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/firewalld-0.3.4-1.fc19
Comment 6 Fedora Update System 2013-08-01 23:49:06 EDT
Package firewalld-0.3.4-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firewalld-0.3.4-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14046/firewalld-0.3.4-1.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-08-03 20:09:41 EDT
firewalld-0.3.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.