Bug 98698 - Makefile and python compilation
Summary: Makefile and python compilation
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhpl   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-07 17:37 UTC by Brian Long
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 18:19:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Long 2003-07-07 17:37:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
Makefile.inc defines PYTHON as python2.2, but Makefile explicitly calls
"python".  This means the byte-compiles will not work when recompiling rhpl on
an older release like RH 7.3 (since "python" is python 1.5).  A simple patch to
the Makefile fixes this problem.

Version-Release number of selected component (if applicable):
rhpl-0.93-1

How reproducible:
Always

Steps to Reproduce:
1. Extract rhpl src RPM.
2. Try to rebuild on Red Hat 7.3.
3. Compiling comps.py and other python code will fail due to "python" command
calling python 1.5 instead of 2.2.
    

Actual Results:  When I patched the Makefile, I was able to properly build the
rhpl RPM including all .pyc files.

Additional info:

--- rhpl-0.93/Makefile.orig     Mon Jul  7 10:20:18 2003
+++ rhpl-0.93/Makefile  Mon Jul  7 10:20:45 2003
@@ -25,7 +25,7 @@

        for d in $(SUBDIRS); do make -C $$d install; done

-       python -c "import compileall;
compileall.compile_dir('$(DESTDIR)/$(PYDIR)', 3, '$(PYDIR)', 1)"
+       $(PYTHON) -c "import compileall;
compileall.compile_dir('$(DESTDIR)/$(PYDIR)', 3, '$(PYDIR)', 1)"

 tag:
        cvs tag -cFR $(CVSTAG)

Comment 1 Jeremy Katz 2003-07-07 18:12:32 UTC
Fixed in CVS

Comment 2 Brian Long 2003-12-16 18:19:58 UTC
This bug can be closed.


Note You need to log in before you can comment on or make changes to this bug.