Bug 9870 - RH 6.1 does not support more than 65535 cylinders
Summary: RH 6.1 does not support more than 65535 cylinders
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-29 21:24 UTC by de_oosies
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-07 19:52:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description de_oosies 2000-02-29 21:24:23 UTC
RH 6.1 does not support harddisks with more than 65535 physical cylinders.
On such disks (e.g. the IBM Deskstar 34GXP), the installer complains about
not begin able to read the partition table on the disk. Fdisk says 'cannot
open /dev/hda' or something similar. The kernel does report the correct
size and partition layout in the boot messages.

The cause appears to be a flaw in the kernel, which uses a 16-bit field to
store the cylinder count. Patches are available, reference
http://www.win.tue.nl/math/dw/personalpages/aeb/linux/Large-Disk-12.html

It should be sufficient to provide a new boot disk with a patched kernel
(provided the installer can be made to copy the kernel from the boot disk
instead of the CD). Hopefully, this problem will be resolved sooner rather
than later!

Comment 1 Michael Fulbright 2000-03-07 19:52:59 UTC
This is fixed in the 2.2.14 kernel, available in our latest beta release.


Note You need to log in before you can comment on or make changes to this bug.