Bug 98703 - include/asm-generic is not included in kernel-source
include/asm-generic is not included in kernel-source
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-07 14:46 EDT by ajs
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-14 13:15:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description ajs 2003-07-07 14:46:47 EDT
Description of problem:
The headers in include/asm-generic are included by many headers in
include/asm-i386 but include/asm-generic is not part of the kernel-source .rpm.

Version-Release number of selected component (if applicable):
kernel-source-2.5.74-1.10
Comment 1 Arjan van de Ven 2003-07-07 16:28:13 EDT
ehm actually kernel-source DOES have all the asm-generic headers.....
Comment 2 ajs 2003-07-07 16:56:17 EDT
Oops!  You are right.

I just looked in /lib/modules/2.5.74-1.10/build/include/ and assumed it belonged
to kernel-source like the 2.4 series.

rpm says that /lib/modules/2.5.74-1.10/build/include/ belongs to kernel.  IT
does not have asm-generic because /lib/modules/2.5.74-1.10/build is not a
symlink to ../../../usr/src/linux-2.5.74-1.10.

VMware looks in /lib/modules/`uname -r`/build/include/ when it builds its
modules.  I understood this to be the standard.
Comment 3 Arjan van de Ven 2003-07-07 16:58:56 EDT
Oh.

yes vmware is correct and indeed this directory is missing; I'll add it for the
next build.
External module building isn't quite expected to work yet; I know some other
stuff that also will need to happen and I'm going to do that soon.
(fwiw I'm trying to get near daily builds on my people page so stay tuned ;)
Comment 4 ajs 2003-07-07 17:29:35 EDT
FYI: I copied asm-generic over to the right place and am running VMware now.  No
problems thus far.

Note You need to log in before you can comment on or make changes to this bug.