Bug 987059 - Inaccurate error message when building with a wrong <programlisting> "language=" attribute
Inaccurate error message when building with a wrong <programlisting> "languag...
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 11:40 EDT by Petr Bokoc
Modified: 2013-12-18 21:46 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 21:46:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Bokoc 2013-07-22 11:40:40 EDT
Description of problem:
BZ#919474 changed the "language" attribute in the <programlisting> tag so that it's no longer case sensitive. It works; however, if you specify the parameter as completely wrong (not just wrong case), you get the following error:

>       'sdaglhkisud' is not a valid language for highlighting. Language names are case sensitive.

Version-Release number of selected component (if applicable):
publican-3.1.5-0.fc17.t62.noarch

How reproducible: 100%

Steps to Reproduce:
1. use a <programlisting> tag in a book with a nonsensical "language" attribute
2. build the book

Actual results:
An error message tells you that language names are case sensitive.

Expected results:
An error message tells you that you probably misspelled the language, or used one that isn't supported.

Additional info:
Comment 2 Jeff Fearn 2013-09-23 01:03:15 EDT
Removed second sentence since language names are no longer case sensitive.

To ssh://git.fedorahosted.org/git/publican.git
   c66b2d0..ff6375f  HEAD -> devel
Comment 3 HSS Product Manager 2013-09-23 01:07:37 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 4 Ruediger Landmann 2013-10-10 23:08:02 EDT
Verified in publican-3.9.9-0.fc19.t4.noarch

undefined language: sdaglhkisud at /usr/share/perl5/vendor_perl/Syntax/Highlight/Engine/Kate.pm line 621.
LibXSLT: error coming back from perl-dispatcher in pm file. 
        'sdaglhkisud' is not a valid language for highlighting.
 at /usr/lib64/perl5/vendor_perl/XML/LibXSLT.pm line 81.

Note You need to log in before you can comment on or make changes to this bug.