Bug 987084 - jacoco: Depmap file is installed in wrong subpackage
jacoco: Depmap file is installed in wrong subpackage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jacoco (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: 985674 985682
  Show dependency treegraph
 
Reported: 2013-07-22 12:40 EDT by Mikolaj Izdebski
Modified: 2014-01-12 19:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 16:06:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.94 KB, patch)
2013-07-22 14:31 EDT, Mikolaj Izdebski
no flags Details | Diff
Proposed patch (1.94 KB, patch)
2013-07-22 14:32 EDT, Mikolaj Izdebski
no flags Details | Diff

  None (edit)
Description Mikolaj Izdebski 2013-07-22 12:40:27 EDT
Description of problem:
Depmap file for maven-plugin is installed in the main package.  Because of that the main package provides mvn(org.jacoco:jacoco-maven-plugin) virtual package, but the actual plugin is not installed there.  This breaks auto-requires.

Reproducer:
repoquery -f 'mvn(org.jacoco:jacoco-maven-plugin)'

Expected result:
jacoco-maven-plugin-0:0.6.3-2.fc20.noarch

Actual result:
jacoco-0:0.6.3-2.fc20.noarch

Version-Release number of selected component (if applicable):
0.6.3-2

Additional info:
[1] http://fedoraproject.org/wiki/Packaging:Java
[2] http://fedoraproject.org/wiki/Packaging:Guidelines
Comment 1 Krzysztof Daniel 2013-07-22 14:26:40 EDT
Frankly speaking, I have no idea how to fix this.
jacoco-maven-plugin lists two files
%{_javadir}/jacoco-maven-plugin.jar
%{_mavenpomdir}/JPP-jacoco-maven-plugin.pom

main package has
%{_mavendepmapfragdir}/%{name}
%{_mavenpomdir}/JPP-%{name}.pom
%{_mavenpomdir}/JPP.%{name}-org.jacoco.agent.rt.pom
%{_mavenpomdir}/JPP.%{name}-org.jacoco.ant.pom
%{_mavenpomdir}/JPP.%{name}-org.jacoco.agent.pom
%{_mavenpomdir}/JPP.%{name}-org.jacoco.core.pom
%{_mavenpomdir}/JPP.%{name}-org.jacoco.report.pom

I really have no clue why jacoco-maven-plugin is listed as a part of the main package.
Comment 2 Mikolaj Izdebski 2013-07-22 14:31:04 EDT
Because Maven fragment file is installed as part of the main package.
You need to use separeate fragment file for plugin artifact.
Comment 3 Mikolaj Izdebski 2013-07-22 14:31:19 EDT
Created attachment 777006 [details]
Proposed patch
Comment 4 Mikolaj Izdebski 2013-07-22 14:32:41 EDT
Created attachment 777007 [details]
Proposed patch

Note You need to log in before you can comment on or make changes to this bug.