Bug 987133 - resize2fs tests failing on ppc, s390
resize2fs tests failing on ppc, s390
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
7.0
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Carlos Maiolino
Filesystem QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 15:02 EDT by Eric Sandeen
Modified: 2015-01-20 13:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-20 13:58:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2013-07-22 15:02:27 EDT
commit e79a9395b382e831c125d000d2bf16ba4b6253d4
Author: Theodore Ts'o <tytso@mit.edu>
Date:   Sun Mar 31 20:34:24 2013 -0400

    tests: add more tests for off-line resizing
    
    Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>

added several resize tets, most of which fail on ppc and/or s390.

For now the tests are commented out in the RHEL7 e2fsprogs-1.42.8 build because they are apparently not regressions - just to get it building.  But these are real flaws that need to be fixed soon.
Comment 2 Lukáš Czerner 2013-10-03 10:54:06 EDT
Hi Eric,

from my testing on ppc64 e2fsprogs-1.42.8 directly from upstream works without any problems. Upstream version from git works as well. RHEL7 version obviously works as well. None of the tests included in that commit failed in my testing.

Unfortunately I was not able to test this on s390 yet.

Thanks!
-Lukas
Comment 3 Lukáš Czerner 2013-10-04 04:41:22 EDT
I do not really know where is a problem but I could not reproduce this on s390 either. What do you think Eric ?

-Lukas
Comment 4 Eric Sandeen 2013-10-04 14:26:13 EDT
Hm the rpm build does still fail for me:

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=6372374

there are only 2 small patches on the specfile, I don't think (?) either should matter.
Comment 10 Ludek Smid 2014-06-26 06:47:22 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.
Comment 11 Ludek Smid 2014-06-26 07:15:42 EDT
The comment above is incorrect. The correct version is bellow.
I'm sorry for any inconvenience.
---------------------------------------------------------------

This request was NOT resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you need
to escalate this bug.
Comment 12 Carlos Maiolino 2015-01-20 13:58:57 EST
The package is now being built properly with the tests enabled.

A few problems with endianess were found and fixed.

So closing it.

Note You need to log in before you can comment on or make changes to this bug.