Bug 987238 - History has an unnecessary compare button
History has an unnecessary compare button
Status: CLOSED WORKSFORME
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
development
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Damian Jansen
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 00:06 EDT by Damian Jansen
Modified: 2014-07-28 01:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-28 01:28:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-07-23 00:06:17 EDT
Description of problem:
Translation history has two "Compare ver. x and y" methods, which point to the same place.

Version-Release number of selected component (if applicable):
Dev

Steps to Reproduce:
1. Alter a translation target twice
2. Press the History icon
3. Press Compare on both items in history

Actual results:
Both the button and the tab text change to say "Compare x and y" but they both point to the same place - the tab.

Expected results:
There's no need to have a button, the tab is enough. 
It would be nicer if the tab changed to say "Compare ver. 1 and ?" on the first click, just to show the user they're doing the right thing.
Comment 1 Luke Brooker 2013-07-23 00:17:42 EDT
I agree the button makes no sense. In the future we can improve the interface overall, but the button is not needed now. I also did some tweaks to the interface(in the dashboard branch) that make it even less necessary.
Comment 2 Damian Jansen 2014-07-28 01:28:44 EDT
Looks like this got fixed at some point
Tested 3.5.0-SNAPSHOT (git-server-3.4.2-201-ge0afdde)

Note You need to log in before you can comment on or make changes to this bug.