Bug 98725 - Screenlock freezes X
Screenlock freezes X
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-07 19:14 EDT by Pradeep K Sadanapalli
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 01:50:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/XF86Config file (3.17 KB, text/plain)
2003-07-08 10:24 EDT, Pradeep K Sadanapalli
no flags Details
/var/log/XFree86.0.log file (31.85 KB, text/plain)
2003-07-08 10:26 EDT, Pradeep K Sadanapalli
no flags Details
glxinfo output (3.06 KB, text/plain)
2003-07-08 10:33 EDT, Pradeep K Sadanapalli
no flags Details

  None (edit)
Description Pradeep K Sadanapalli 2003-07-07 19:14:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612

Description of problem:
OS              : RedHat 9
Kernel          : kernel-2.4.20-18.9
GCC             : 3.2.2-5
GLIBC           : 2.3.2-27.9 
XFree86         : 4.3.0-2
KDE             : 3.1.2

Nature of this problem   : Random

I have configured my screensaver to lock the screen . So when my screensaver
kicks in after a certain period of idle time, it starts running fine for some
amount of time. When I touch my mouse or keyboard to login back, the password
promt is diaplayed and immediately the X system is frozen. Nothing responds now.
No keyboard. But I can login with ssh and kill the X server , so that the system
is restored to it's original state.  This is observed to be random in nature. I
observed this with SolarWinds screensaver and other openGL screensavers. 

Is it problem with redhat RPMs or is it a bug in KDE or X ? Has anyone observed
this problem or is it just me? Please help with this....

Version-Release number of selected component (if applicable):
kdebase-3.1.2

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. Could not reproduce when I wanted, but it happens randomly often
2.
3.
    

Actual Results:  Could not reproduce when I wanted, but it happens randomly often

Expected Results:  the X windows should not freeze while logging back , after
screensaver has locked the screen

Additional info:
Comment 1 Ngo Than 2003-07-08 06:00:30 EDT
it looks like a bug in XFree86. Which graphic card do you have in your machine.

Could you please send following files:
  /etc/X11/XF86Config
  /var/log/XFree86.*
Comment 2 Pradeep K Sadanapalli 2003-07-08 10:24:40 EDT
Created attachment 92796 [details]
/etc/X11/XF86Config file
Comment 3 Pradeep K Sadanapalli 2003-07-08 10:26:41 EDT
Created attachment 92797 [details]
/var/log/XFree86.0.log file
Comment 4 Pradeep K Sadanapalli 2003-07-08 10:33:21 EDT
Created attachment 92798 [details]
glxinfo output 

I attached the files 1. /etc/X11/XF86Config  2. /var/log/XFree86* 3. glxinfo
output above. The video card on my Dell C610 laptop is ATI Radeon Mobility M6
and on Dell GX260 desktop is ATI Radeon 7000 . DRI is enbled in the kernel. I
even tried with the latest XFree86 version from redhat rawhide and also updated
KDE to the latest from redhat rawhide. The problem still exists. Can you please
point to me where the could be exactly?
Comment 5 Pradeep K Sadanapalli 2003-07-08 11:31:59 EDT
I have tried to reproduce this bug. I ran the command "#kdesktop_lock --
forcelock" and then while trying to enter something into the password field, I 
tried to move mouse and pressed keyboard ( ESC etc. ), then I observed this 
problem. X froze. But I only observed this problem when I am running the 
screensaver "SolarWinds" that to in the setup, when it is configured to Regular 
mode only. Other modes doean't seem to give this problem.  
So is this the problem with solarwinds screensaver only or does it have 
anything to do with DRI and 3D acceleration?? Any ideas?
Comment 6 Pradeep K Sadanapalli 2003-07-08 12:15:59 EDT
I observed one more thing with this problem...
When the screensaver is running, I tried to press ESC continuously while moving 
my mouse, and it freezes the system .  The problem is observed only with the 
OpenGL screensavers from KDE. when the system is frozen, I logged in remotely 
via SSH and killed the screensaver program , not kdesktop_lock . Then the 
system is back. So what I feel is it is the problem with screensavers, not 
screenlock . Screensavers freeze X. 
Comment 7 Mike A. Harris 2003-07-17 03:45:10 EDT
I notice the following is in your config file:

     VideoRam    16384

Remove that line from the config file.  Never specify your video ram in the
config file, the video driver will detect it automatically and correctly.

That setting is for ancient video hardware that contains bugs that don't allow
reliable video RAM detection.  All modern video hardware does not have that
problem and you should never specify the amount of video RAM.

Please try the screensaver again after removing that line and restarting X.

If the problem is still there with Solarwinds after that, comment out the line
that says:

    Load "dri"

Restart X again after that.  If the solarwinds screensaver does not cause a
problem while DRI is disabled, then this problem is likely a 3D acceleration
problem.  If this is the case, please attach your /var/log/messages from after
an X lockup has occured and we can possibly explore the problem deeper.

TIA
Comment 8 Mike A. Harris 2003-07-17 04:03:34 EDT
Doh!  One thing I forgot to ask... you mention 2 video cards above.  Does
this mean you can reproduce the problem on both the laptop and the Radeon 7000
in the desktop?  If so, that is very helpful info, as I don't have access
to Radeon M6, but I do have Radeon 7000 available.  Also, is the Radeon
7000 PCI or AGP?  I presume AGP.

thanks again
Comment 9 Mike A. Harris 2004-10-01 01:50:55 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.