Bug 987325 - ~/.publican.cfg doesn't work properly with non-ASCII characters
~/.publican.cfg doesn't work properly with non-ASCII characters
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 05:08 EDT by Petr Bokoc
Modified: 2013-12-18 21:46 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 21:46:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Bokoc 2013-07-23 05:08:34 EDT
Description of problem:
Setting up a name (firstname or surname) containing non-ascii characters in ~/.publican.cfg and using "publican add_revision" will result in broken encoding inserted as the revision creator's name into Revision_History.xml

Version-Release number of selected component (if applicable):
publican-3.1.5-0.fc17.t62.noarch

How reproducible: 100 %

Steps to Reproduce:
1. Add the following into your ~/.publican.cfg file:
   firstname: Petr
   surname: Bokoč
2. In any book's directory, run:
   $ publican add_revision --lang=en-US --member=foo
3. Inspect the Revision_History.xml file

Actual results:
Revision_History.xml has a new entry containing <surname>Bokoč</surname>.

Expected results:
Revision_History.xml has a new entry containing <surname>Bokoč</surname>.

Additional info:
Overriding the the surname inside the actual command ($ publican add_revision --lang=en-US --member=foo --surname=Bokoč), the non-ascii character is inserted properly. The problem is isolated to the ~/.publican.cfg configuration file.
Comment 2 Jeff Fearn 2013-09-17 03:50:54 EDT
AFixed UTF8 issues.
Comment 3 HSS Product Manager 2013-09-18 01:28:12 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 4 Ruediger Landmann 2013-10-10 23:00:19 EDT
Verified in publican-3.9.9-0.fc19.t4.noarch

Note You need to log in before you can comment on or make changes to this bug.