Bug 987372 - JBWS2150TestCaseForked fails on Windows and HP-UX with JDK 7
Summary: JBWS2150TestCaseForked fails on Windows and HP-UX with JDK 7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services
Version: 6.1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER3
: ---
Assignee: Alessio Soldano
QA Contact:
URL:
Whiteboard:
Depends On: 1006789
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-23 10:24 UTC by Rostislav Svoboda
Modified: 2013-12-15 16:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-15 16:55:53 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Rostislav Svoboda 2013-07-23 10:24:31 UTC
JBossWS-CXF 4.1.4.Final + EAP 6.1.1 ER3 - client side is mainly upstream because of BZ 985894.
I didn't happen on Solaris and RHEL, only on Windows and HP-UX.
For Windows I didn't see these failures on one machine (vmg42) but on another (dev98) they were present. Working on debug job with more machines to identify how often it happens.

the main problem is:
javax.xml.ws.WebServiceException: Could not send Message.
	at org.apache.cxf.jaxws.JaxWsClientProxy.invoke(JaxWsClientProxy.java:145)
	at com.sun.proxy.$Proxy26.echo(Unknown Source)
	at org.jboss.test.ws.jaxws.jbws2150.JBWS2150TestCaseForked.checkWsdlAndInvokeCodeFirstEndpoint(JBWS2150TestCaseForked.java:520)

....

Caused by: java.net.UnknownHostException: UnknownHostException invoking http://myloadbalancer.com:8080/jaxws-jbws2150-codefirst/CodeFirstService: myloadbalancer.com



Example of test failure
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-WS/job/eap-6x-jbossws-testsuite-hpux/1/BITS=-d64,jdk=jdk17_hpux,label=hpux11v3/testReport/org.jboss.test.ws.jaxws.jbws2150/JBWS2150TestCaseForked/testRewriteCodeFirst/

Test results:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-WS/job/eap-60-jbossws-testsuite-windows/52/testReport/
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-WS/job/eap-6x-jbossws-testsuite-hpux/1/BITS=-d64,jdk=jdk17_hpux,label=hpux11v3/testReport/

Comment 3 Rostislav Svoboda 2013-07-24 07:31:21 UTC
*HP-UX*
 - failures are stable - 2 runs on 4 machines
java -d64 -version
java version "1.7.0.06"
Java(TM) SE Runtime Environment (build 1.7.0.06-jinteg_2013_05_16_04_24-b00)
Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01-jre1.7.0.06-rc2, mixed mode)

*Windows*
 - failures are random - 3 runs on 8 machines
 - only 6x PASS, 18x FAIL
java -version
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

Comment 4 Rostislav Svoboda 2013-07-24 07:33:00 UTC
Additional info for Windows - test failed and passed on the same machine - see run #2 vs. #1 and #3

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-60-jbossws-testsuite-windows-bz987372/jdk=java17_default,label_exp=vmg42-w2k8r2-x86_64/

Comment 5 Alessio Soldano 2013-08-26 12:25:10 UTC
Upstream fix: https://issues.jboss.org/browse/JBWS-3692

Comment 9 Petr Sakař 2013-10-10 12:26:12 UTC
verified failures are no more present for EAP 6.2.0.ER5


Note You need to log in before you can comment on or make changes to this bug.